Steam shows i am ingame in Supcom when FAF is open

0

Hi,

since the newest client update whenever i have the client open Steam shows me as ingame in Supreme Commander Forged Alliance. I can also not have FAF open without Steam or close Steam without closing FAF first.
One of my friends has this problem aswell, but noone else as far as i can tell.

Is this a known bug?

1

It is a known future

0

@eternal said in Steam shows i am ingame in Supcom when FAF is open:

It is a known future

Thatโ€™s a great feature. Happy to advertise FA to my steam friends.

Check out my maps here:

Madness 1 - 9

https://forum.faforever.com/topic/480/h-master-s-maps

0

@eternal said in Steam shows i am ingame in Supcom when FAF is open:

It is a known future

Does this mean it is since the new update or was it a bug even before that? Is it getting fixed soon or is there a workaround?

0

@nuggets This a new Feature apart of the new client update

"The needs of the many outweigh the needs of the few" - Spock

1

@rowey said in Steam shows i am ingame in Supcom when FAF is open:

@nuggets This a new Feature apart of the new client update

This is supposed to be a feature??? Can i downgrade lol

In all seriousness i usually have the client open whenever my PC is on. But i don't want to be shown ingame all the time. If I'm in a lobby sure but i won't be using the client like this

0

A lot of other clients operate in a similar manner - we just copied their behavior.

A work of art is never finished, merely abandoned

0

Can you just not appear invisible on Steam? There may be other ways to hide the fact your spending too much time playing FAF as well ๐Ÿ˜‰ Just Google it (or close the client!)

0

still showing you as ingame, because you have the launcher open should be an option.
Or it should at least show, that your just in the launcher or something.
I believe showing it as a separate game (like listing it as forged alliance forever in steam) is not possible i guess?

1

I don't mind it affecting the Steam status, but it tries to open the Steam overlay ingame, and that seems to cause crashes on alt-tab for me (turning off steam before launching FAF fixes this).

The crash specifically is due to the dx9 device being "lost".

I've updated all my drivers, which I thought fixed the issue, yesterday, but it's now reoccurred.

1

I kicked my brother off a competitive CS match because I launched FAF with Steam open. We share a Steam account so now I have to make sure Steam is closed before I launch FAF

put the xbox units in the game pls u_u

0

@auroraraven I disabled the entire steam overlay for all games because of this new FAF feature

5

@Sheikah can you make it optional?

My github repo with UI Mods

2

Please make it optional

1

I would also like it if this was an optional feature.

In the meantime you can revert back to the previous client version here https://github.com/FAForever/downlords-faf-client/releases/tag/v2022.5.0

Proper feedback should go here. https://forum.faforever.com/topic/4244/client-2022-6-0-features

0

Optional as a whole, or optional as only be shown as playing supcom when actually playing supcom?

0

As a whole. I've detailed some reasons why in the proper feedback thread.

1

@zeldafanboy said in Steam shows i am ingame in Supcom when FAF is open:

I kicked my brother off a competitive CS match because I launched FAF with Steam open. We share a Steam account so now I have to make sure Steam is closed before I launch FAF

That will teach him. Great time to introduce him to FAF ๐Ÿ˜‰

Check out my maps here:

Madness 1 - 9

https://forum.faforever.com/topic/480/h-master-s-maps