EternalStrategicIcons [UI]

1

Version 2

Due to problems with compression (losing pixel colors = game renders them with player color) i changed final colors.

  • White - something dangerous, that should be destroyed
  • Blue - something defensive

Added:

  • TML
  • TMD
  • T3 Arty

8837bd9a-a456-4ce8-8a11-df341fc043a7-image.png

0

Nice, that definitely works for me, good stuff.

0

Works for me too - very clean and matches the style 🙂

A work of art is never finished, merely abandoned

0

Very nice icon set. Still a little bit small for 4k (or I'm just a masochist for using 4k in the first place); I thought from the description it would look bigger (since stock icons on 1440p are fine).

0

@cyborg16 sorry, made this set for full HD (1920x1080) mostly.

0

woah, great job

2

Guys I have to say, this mod is fantastic and everyone needs to get it. Just improves the icons, makes things much easier to understand at a glance and it doesn't make large changes which can confuse. Literally no downside to this mod 🙂

Support FAF on their Patreon
Rule #1 of FAF : Kill the ACU nothing else matters...

0

Hello, I have a question. Not quite for this mod, but more for the problem with the loading of any "Strategic Icons mods". But this topic is the most recently updated, so...
   First the background: I installed "Supreme Commander" and the "FAF client" into a clean system. I launched one replay from the online vault, go «F10» -> «End Replay» to the "Main Menu", created a "Game Profile", changed the game settings, and exited. I installed several mods in "FAF client", watched a few more replays and noticed that the "Strategic Icons mod" does not work.
   I started checked the "Strategic Icons mods" «SACU Icons», «Redux Strategic Icons Small», «ACUhighlight», «Penguins Icon Mod» and «EternalStrategicIcons». One by one, I activated them in the "FAF client" via the «Mods» -> «Manage active mods» and launched a replay (fresh, from 11.04.2022) to check. In the panel of «SupremeScoreBoard» mod, they are shown in the list as active, but the "Strategic Icons" do not change.
   I found out experimentally that by launching the "Skirmish" from the "Main Menu" after exiting the replay (and skipping the "Tutorial" offer), or later after creating and launching the map in the "FAF client", the "Strategic Icons" from the mod loading and begin to be displayed, including in replays. If you activate another "Strategic Icons mod" in the client, but do not create a game, then the new mod will be shown in the panel of «SupremeScoreBoard» mod in the list of active mods, but the "Strategic Icons" of the old mod will remain in the replays.
   At the end I tried to delete the file "\AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance\game.prefs" (also, I don't have a «UI-Party» mod). First I had to re-create the "Game Profile" through someone else's replays (from my replay, whether local or from online vault, game did not go to the main menu đŸ˜Č ), then I turned on the mods. The "Strategic Icons" have not loaded again.
   How can I try fix the "Strategic Icons" loading process?

0

What would it take to create an option to scale up the icons for 4k?