Legacy client not working

0

Not even sure it's called the legacy client but I'm pretty sure it is. Was working just fine and about a week ago I tried using it and it won't load anything, shows all players that are on but everybody is grey and no games show up. Does the legacy client not work anymore?

I tried using downlords client but it's just god awful, is there anything else?

0

An update to the server broke compatibility with the legacy client. Downlord's client is the supported version of the client.

0

@Sheikah well, good to know it's not just me, do they plan to fix the issue or is downlords the only one that's going to be supported now?

1

Java client has been the only supported client for several years now. Python client surviving until now was a happy accident. No one will be working on it.

0

There was a pull request done fixing the issue breaking it, it has just not been released.

0

There is nobody left to release it I guess. Last one was Strogo, haven't seen him in a while.

0

@Brutus5000 , oh dear, please bring back faf-legacy-updater, I just finished to fix problems with this client so I could use it again (and even with build problems on my machine, so I could share it with others who really (like me) enjoying it), and now I got server update 18 hours ago. This is ridiculous, don't kill me

0

Just use the new client?

0

@Gatsik it the legacy updater is a security risk

0

I ran a vulnerability scan of the Docker image yesterday and it has over 1.100 (!!) known vulnerabilities, so no I will not bring it back.

0

OK, understood, I just got disappointed that I haven't managed to play a single game after my incredible (as I'm dumb af) efforts. Hope it is possible to find a workaround with what's left.

0

It's more likely to find some body that fixes your issues with the Java client (given you can describe them in a meaningful way).

The features the python client would need to work exist for 4 years now. Nobody bothered so far to implement them.

Log in to reply