Client java.lang.error fix

For those having issues with game.prefs and character encoding problems an alpha client has been released at Which you can try which should fix the problem.

Nice work!

Please, can you give feedback if it fixes your issue with the malformed exception you encountered for "Game.prefs":

Пожалуйста, дайте обратную связь, если это исправит вашу проблему с неправильно сформированным исключением, с которым вы столкнулись для "Game.prefs":

(users who had issues with it)
@eb_ @broodlow @hero_swe @goshawk_27 @the_dark_archon @custos_stsp @dewostator23 @xumuk_911 @rodi @tvelv @amish @iku-turso @n_a_g @opankist @serfed @crimsontyrant @xathos @Glotarj @Empty_exe @Hellpers @FerGanec @xXMadnessXx13 @itstehendz @Scionos @Tatankasapa


can confirm it works for me. Managing active mods in the mod tab and hosting custom games.

@magge I played solo 5 skating rinks and with a friend a couple on alpha, there were no problems with java 👌 😊

@magge Gave me a couple of errors when logging in (which I was unable to copy) but after getting in all worked great. So thank you for the help.

Спасибо огромное, вы спаситель)

I got same issue, it worked for me.

Thanks for the quick fix =D

@magge Установил и пока могу сказать, что проблема решена, Большое спасибо)

Mine seems to still have the same issue after the alpha update,

had the issue and this version worked for me

Sorry for the late reply this fix worked thank you

@magge thank you GIGACHAD!

Having issues joining custom games :-

Client Version: 2023.1.2
java.lang.Error: java.nio.charset.MalformedInputException: Input length = 1
at java.base/java.lang.String.decodeWithDecoder(
at java.base/java.lang.String.newStringNoRepl1(
at java.base/java.lang.String.newStringNoRepl(
at java.base/java.lang.System$2.newStringNoRepl(
at java.base/java.nio.file.Files.readString(
at com.faforever.client.mod.ModService.readPreferencesFile(
at com.faforever.client.mod.ModService.readActiveMods(
at com.faforever.client.mod.ModService.enableSimMods(

The alpha client resolved the issue, however it reset all settings and blueprints.

Same here nad it resets settings every game