issue with launching games

0

Greetings, i've been having this issue for the past few days, when I try making my own game, it says it failed to update mods or something similar with the logs, yet runs the game fine by myself. when my friend joins, a desync occurs. but when i try joining a friend with them as the host, it crashes completely. I have reinstalled my client with no success. I havent tried uninstalling and reinstalling mods yet, ill try that in the meantime. also when i try making a game, it says no mods are selected. yet seems to load them when creating a game. here is my logs from a past few days

game_18716296.log
game_18713716.log
game_18713172.log
game_18713162.log
game_18713146.log
game_18713117.log
game_18713095.log
game_18716359.log
game_18716332.log
game_18716316.log

0

Does it work without any mods activated?

0

@magge the game runs perfectly fine when im playing by myself, and it wont even let me launch a game without any mods cause it force loads my previously used mods even with all disabled. so i dont fully know, however as i am currently uninstalling and reinstalling all my mods, when i uninstalled a mod called "quality of chaos" the exact same error that shows up, had appeared once it uninstalled about "unable to update mod" so that might actually be the source. when im done reinstalling my mods and keeping only the ones i was still actively using, ill provide an update for if its working without that one mod installed at all

0

just tried with no mods, error still shows (im also getting a notification of "cannot update mod states in game.pref)

0

There are several possibilities, that can cause your errors, but I am unable to point the finger who to blame, so we need to do it all:

  1. Move your files out of your onedrive folder and use a "normal" folder, that does not get synced or touched by other software and set the new folder path via FAF

493ae6f7-a3ab-4216-8e1b-dcf8704c4127-image.png

  1. Whitelist FAF/Supreme Commander process and folders in your security software

Delete all mods (make a backup first) from

C:\Users\%username%\Documents\My Games\Gas Powered Games\Supreme Commander Forged Alliance\Mods
  1. Delete Game.prefs (make a backup first) from
C:\Users\%username%\AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance

After all those steps, start Supreme Commander (verify files before with Steam or GOG) via Steam/GOG once and play a game for 3 seconds.

Then start FAF and host a game there without any mods installed.

This needs to work in the first place, before you touch anything mod related. Confirm this, and we can try the mod stuff again.

0

done, no issues so far

0

Great - Now you need to install and activate each mod one by one until you find the mod that crashes. This can be very tedious and time-consuming work, but there is no other way around it.

Better you clear your logs, so you start with a fresh batch.

0

ok so, i had to do it twice (got a little impatient and had to revert my progress a little for it) but ive located the mod. its "EXMEX Rebalanced" as upon downloading it, i went to go and test and instantly the menu for choosing mods was showing every one of my mods not selected and i know if i load my game, itll have the error log