Login Screen forever

0

Stuck on login screen with no error, it just keeps connecting forever. I didn't have any issues with the older client but I updated to the new one and now it's just stuck.

0

if help didnt help you, you can try old client

0

I have the same problem
307d250c-ecf9-42dc-9a38-6b2e31dab5c1-image.png

I try a few different versions, but without any results

0

@tgoat that looks like your client can't contact the FAF server try checking your firewall or antivirus

0

Capture.PNG

I'm getting past that part. I'm just stuck at this point forever

0

This might be a stretch but I recently started having a similar issue every once in a while. I fix it by fully restarting both my pc and my router.

Edit: I think this is actually something weird going on with my router because I have another completely unrelated issue where I have to restart the router to clean its cache to get some of my ssh sessions to work. That's completely unrelated to faf, but might have a similar cause with whatever my router is doing.

0

I've tried everything I can think of, including restarting my router. I'm at a loss here

1

From what I have seen @Ryan555 this is commonly a dns issue where the client can't resolve lobby.faforever.com. You could try manually inserting the ip for the lobby by double-clicking the environment button at the bottom before you log in.

0

I've been waiting for them to fix this for literally like a year now and despite countless updates since last I even tried and they still can't seem to figure it out or fix it. I gave up and moved onto games like BAR, I'm pretty heavily disappointed with FAF.

5

What do you expect? We have over 20.000 users per month who do NOT have this issue.
If there is a minority of people with weird problems it's a fair assumption to say it's a problem with your computer / operating system / local network setup.
We have seen plenty of logs who describe this problem. Technically there is no reason that the FAF client can't resolve our domain or things like that. Java is running on millions of computer without problems so it's not a Java problem. It's not a code problem. Most probably it's weird firewall problems etc. It is impossible to track from our end.

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
– Benno Rice

0

As Brutus said this unfortunately only occurs for a minority of users. I have personally tried modifying my system and network configurations however I have never been able to reproduce this on my own machine or setup. This unfortunately makes it impossible for me to figure out how to solve this or if there is anything we can do on our end to help.

0

Well I already did everything that was suggested to fix this problem, so my answer to that question is pretty much "I would hope it would've been fixed by now considering I've never had these issues with old versions of FAF."

It also seems quite callous to disregard the minority of people having the problem over the majority, especially considering this has been a long time issue now.

0

As others have already tried to explain, we are out of ideas what could be causing it. And we have no way of reproducing the problem and thus are unable to try things out and checking if that makes the problem go away. So what do you suggest we do?

0

Do you have the same problem on a different pc?
Do you have the same problem on a different network?

Check out my maps here:

Madness 1 - 9

https://forum.faforever.com/topic/480/h-master-s-maps

0

@blackyps Considering that this problem started happening in general during the switch from python to java then it is quite obvious someone messed up.

0

@lordyellow Nothing is obvious when it comes to unreproducible software/networking bugs

Are people still able to log in with the Python client, and if so, have you tried doing that?

Have you tried logging in from a different connection? For example if you go over to your friend's house and use their internet, or a Starbucks with wifi, or whatever

0

@arma473 I would be most grateful if you could supply me a way to get the old python client. I don't have it anymore since I updated long ago.

Also yea I tried logging in from different spots, just keeps giving me the same issue.

0

I don't have a copy of the python client but @ThomasHiatt might

Have you tried logging in from a different computer entirely? You can put FAF on a computer without installing Steam and FA. The point would just be to see if you can log in, not to actually play the game on some other computer.

0

Yea, I'm the only member of this community that can type "faf python client" into google.

https://github.com/FAForever/client/releases

0

Python client uses same web authorization as official one. The problem is in local network that does not give permission to connect FAF OAuth server in Germany. I had such problem in my college, as i know there is setup of a local server with some firewall rules, so problem is not on FAF side.

If you are using router / everything that stands between you and the Internet, the problem may be in it. Network provider will never block such stuff