FA windows go light grey after setting up dual monitor screens

I just changed the setting to use two screens in the SC menu and now both windows show nothing but a light grey colour, obviously the settings are wrong but has anyone foudn this issue and know how to set up dual monitors properly? ty

I'm afraid that you can't do that. I am even considering removing the option from the FAF version of the game. Only Windows XP supported that if I am not mistaken šŸ™‚ . You can reset it by looking into your preference file and changing it there.

A work of art is never finished, merely abandoned

@jip Thanks. So there is no dual screen support for FAF at all??

You can 'cheat it' via a UI mod and span the screen across both monitors in windowed mode. But I am not aware of how.

A work of art is never finished, merely abandoned

@specialk I use dual monitors. I have two 4k monitors, one in landscape and one in portrait. My OS is Windows 10.

I don't know how to describe the setup I have other than: in the game options, my "primary adapter" is 3840x2160 and my "secondary adapter" is 2160x3840. It works fine.

@arma473 OK, this is basically what I did, so it is possible then I guess. You're not using a mod?

My screens are a monitor (1920x1080) and a TV (1366x768) and i got the same figures in the game menu. Not sure what could be wrong

@jip I can't seem to find this preferences file is it in faf client folder?

You can find it via the client:


A work of art is never finished, merely abandoned

At the moment, I am using a couple mods, but I think the game works without them. I turn the mods off when I'm going to watch an old replay, and the two monitors work fine.

The first thing I would try is turning the resolution way down, to the lowest setting for each monitor, to see if that works.

On a basic level this hapoens with how things get cached. Notably Window to Full or vice versa. Is most common cause. But whenever the resolution is chanhed from prior start up can cause it

Iā€™m a shitty 1k Global. Any balance or gameplay suggestions should be understood or taken as such.

Project Head and current Owner/Manager of SCTA Project

This post is deleted!

thanks y'all. I changed the lobby settings from windowed to full screen and it's now working perfectly fine. I actually dont know if this fixed it but the tv is now megaminimap so thats cool


@Jip Dual monitor never ran stable, even on xp it caused weird crashes and odd mouse behavior. Please remove the setting.

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
ā€“ Benno Rice

But apparently it works for some. I can add a warning to it that it is unstable.

A work of art is never finished, merely abandoned

I was able to run the dual monitor setup fine for couple of years on windows 10. But the fake fullscreen is just way more convenient when you spent the time setting it up. But another friend of mine also had issues with dual monitor FA when he added a 3rd screen.

I've run dual monitor for SCFA since it came out. I have never experienced any instability as a result of that. Alt-tab on the other hand, is really unstable, especially since Windows 7 arrived. I haven't yet moved to Windows 11 (On 10 atm), but I have dual monitor configurations on all my units here (4 full rigs), and none of them have any issue with dual screen SCFA.

Having a 3rd screen, I can confirm, does NOT work. In order to get that configuration to work, the 3rd monitor must be disconnected when you start the application, otherwise it's just confused.

@jip sorry for the old thread revival but what exactly am I looking for to change in the prefs file?

@capablemite In the game.prefs file, search for primary_adapter. You should get 2 results:

  • one will be nested together with the rest of the settings you can change in the games Options menu
  • the other will be with a bunch of resolution choices.

You want the one nestled with the other in-game Options settings. Change the value for that primary_adapter to windowed. You should also see secondary_adapter within that same section of the in-game Options. Change that to disabled.

After making those changes, save your changes while being sure to change the File Type to All so that your saved document saves with the name game.prefs instead of something like game.prefs.txt or similar.

This should allow to you to get into the game & then you can go to the in-game Options > Video to select the resolution you want.

@mostlostnoob Make this person a mod! Dude came from the client to here to answer my question, I really appreciate it buddy, worked like a charm!

This post is deleted!