FAF No Sound Problem

When I start a game, the first 5 mins or so everything is fine, but then all sounds turn off. I've been nuked twice without even knowing because there's no sound. I just play in complete silence. Sometimes the music comes back for like a minute then goes off, it does this throughout the game.

Things I've tried: Restarting my PC, verify my files on Steam, updated the launcher, Uninstall/Reinstall the base game and the FAF client, no luck. I tried going into my bios but couldn't find what to disable.

Please help.

@breezy1 There is a "sound bug" that manifests as: every unique sound will play only once.

The first time a striker fires a shot, you hear it. But after that, every striker shot is silent. Etc.

Here is a thread that may have some solutions for you:


@arma473 Already saw that post, no luck.

My solutions to that exact problem are in that thread. Either disable on board audio in bios then restart and re-enable it, or reinstall drivers. The first solution is quickest if you can find the right bios screen

@reckless_charger everytime I press f8 to go into BIOS I get the ASUS Bios which I'm unfamiliar with.

@breezy1 I don't know where the audio chipset setting is in the asus bios. But you could try google for your bios version. Or just click around usually it is somewhere in the chipset settings.

I can't remember the fix(unfortunately) but i think i know the cause; play in FAF then try to play in Steam(jump between them), sound issues ensue....at least this is what happened to me.

i had problems with sounds in cracked version of game

If you really can't find the setting by exploring the bios menus in a logical fashion then google the motherboard and download (and read) the manual.

I have solved this problem, all you need to do is rename the file "C:/ProgramData/FAForever/bin/ForgedAlliance.exe" to SupremeCommander.exe, and create a symbolic link from this file e.g. using the LinkShellExtension tool to the name ForgedAlliance.exe

alt text

After that, if you run the game via FAForever, the binary file will be displayed in the task manager as SupremeCommander.exe (not ForgedAlliance.exe) and the audio will magically start working!

@daviteusz While you may have somehow temporarily resolved your sound issue, this is 100% not a correct method for proper resolution of sound issues as those are derived from incorrectly configured sound devices/drivers or applets/programs that manage the sound that come with the hardware.

On top of that, this will result in an error with updating the FAF game files (specifically the exe) whenever a new version is released as it will not pass the file check function.

I know it's not a great solution, I don't understand at all why after running ForgedAlliance.exe the game doesn't appear in the volume mixer and you can't change the source to some other device, when after running SupremeCommander.exe everything works without any combinations. This is totally stupid, because it's the same file just with a different name 😄

(yes, I know this is old game but... Windows uses some audio volume mixer whitelist? Why? I don't think I'll ever get an answer to that question)

I also discovered that switching the game to the output of another device when the game is started does not work properly using the built-in Windows function.
There is a utility called AudioRouter that does this job correctly.

And forgot to mention, I'm using Windows 11.

I also started losing audio, but probably because my minijack socket has become faulty, and it turning off switches the audio device and it can't go back.

We definitely need textual "Strategic launch detected" for these cases

@MostLostNoob The game has been updated and the symlink has been replaced via new binary file and sound is again gone, so there is no file check function. You can even delete ForgedAlliance.exe file and will be recreated when launching to lobby.

My method is not working anymore after game update 😞
When launching original game it works (SupremeCommander.exe)
When launching FAF (ForgedAlliance.exe/SupremeCommander.exe) does not.

@daviteusz Simple sound issue fix steps are:

  • Windows key > type: Control Panel > Open > Sound > Playback > select the Device you use:
  • Configure > Stereo > finish configuration,
  • Properties:
  • Enhancements > Disable all enhancements,
  • Advanced > 16 bit, 44100 Hz,
  • Spatial Sound > Off,
  • Restart or Shift+Shutdown (not just Shutdown) of PC

If your headphones come with any applet/program, then you may want to disable that & try using the headphones without it. Similarly, if they use a USB or Bluetooth dongle to connect to the PC, see if you can connect directly without the dongle.

See this thread for further troubleshooting: https://forum.faforever.com/topic/4084/solutions-for-snd-error-xact-invalid-arg-xact3dapply-failed

I tried these steps and none of them worked for me.

I don't have a problem when I run the original game, but when I run FAF there is no sound.

I've tried this method:

I replaced SupremeCommander.exe in the steam installation location with the binary file from FAF, created a symbolic link named ForgedAlliance.exe to original location and the sound returned completely.


So... Now FAF launches as original game, Windows likes that.

Works after reboot/shutdown

@daviteusz Doing that is eventually just going to lead to issues with both Steam & FAF.

Since the previously provided methods of fixing the issue didn't work for you, , then the only other thing that I can suggest is installing a 3rd party device/driver like VoiceMeeter or VAC so you definitely have a Stereo device selected as your system audio device which will then re-route the audio to your real device.

Steam version works, FAF version works, and audio works without issues in stereo or 5.1 or even with dolby atmos.

Anyway, thanks for your time.

Edit: I moved C:/ProgramData/FAForever to C:/Games/FAForever and I created symlink to this folder in original location, and this solved all issues with audio Forever.

@daviteusz I think i had the same issue as you and it turned out the fix was as simple as making a shortcut of SC:FA from steam bin folder and putting it into FAForever renamed to "ForgedAlliance"