Game freezes and Crashes in FaF singleplayer and multiplayer 100% of the time within 10-50 minutes.

0

Been trying to play Faf with my friend all day and every single custom game we play, with or without mods, the game freezes and crashes between 10-50 minutes of gameplay, 100% of the time. We tried swapping hosts but that didn't work. Game crash log included. Please help. We just wanna play. We haven't been able to complete a single game.

CrashLog.txt

1

Do you get a crash message or does it just freeze? Try to play separately to find out which one of you have the issue.
As a general tip game likes to crash more often if you have it in fullscreen mode, I recommend using windowed mode.

0

@Giebmasse Theres no error message when the game freezes. The log appears in a separate window though and the game becomes inaccessible and has to be closed with task manager.

0

Update: Windowed mode did not fix it.

0

Update 2: It is just me that is crashing. Whether I'm host or not I crash the multiplayer lobby.

1

Try to update or reinstall your audio driver and set output to stereo.

0

@speed2 I will get back to you on this when I'm available to try it.

1

You can also try to delete these folders:

C:\ProgramData\FAForever\gamedata
C:\ProgramData\FAForever\cache

Then ofcourse reinstall the main game, update your drivers etc. regular troubleshooting.

0

@Giebmasse Trying these now. The aforementioned audio driver fix from speed2 did not work.

0

@Giebmasse Update. Drivers are updated, game is reinstalled and i tried deleting those folders. Nothing worked. Although worth noting that the crash log is slightly different this time, i think. Crashlog2.txt

1

Are you using any mods?

Are you comfortable posting your dxdiag as well?
https://mtgo-support.wizards.com/hc/en-us/articles/360000972706-Creating-a-DxDiag-File

1

Might be worth looking into general PC stability then, memtest etc.

1

It still looks like an audio issue to me, one of your last lines in the crashlog says "warning: SND: Error playing cue 1 on bank 5 [music]". You'll notice it's the same as the ones you were getting in the previous crashlog.

Are you -REALLY- sure you have configured your audio as stereo under windows and not as
5.1/7.1/surround/whatever?

Try looking up your error on google, you'll get some more insights and tips.

It might be a device incompatibility, or it might be because you are plugging it through USB instead of the audio jack, or it might be the device-specific software giving problems (try closing it or double check the settings there).

One of the discussions that you will find mentions deleting the music files from the game as a "fix", you might want to try that (make sure to make a backup just in case, so you won't have to redownload/reinstall).

1

This is definitely a sound configuration issue - the final message in that crashlog that refers to the XACT issue, confirms it.

0

@deletethis It's always been set to stereo so I never tried changing it to something else and back to Stereo. I can try testing it when I'm available again. I use regular headphones plugged into the audio jack of my PC. I'll definitely try deleting the music files too when I'm available again. I'll keep you updated.

5.JPG

0

@Sprouto I'm glad it's narrowed down to that at least. I can try reinstalling audio drivers again when I'm available. But my speaker's configuration has always been set to stereo. I've never changed it.

0

@Pearl12 The only mod I've used, if it counts, is Nomads, but the problem has been happening before and after I've installed Nomads, and after I reinstalled the game.

I'll post my dxdiag if we run out of ideas but from the looks of it. It's a sound issue at the very least.

0

To confirm the diagnosis, use the /nosound switch in your command line - this will disable all sound - and confirm if it's a sound issue that's causing the crashing. Another source of possible sound issues is the additional audio devices that get sometimes get installed with various devices (ie. - monitors with speakers in them, discrete sound cards). Review your audio devices - and disable any that you don't use - or cannot identify - essentially insuring that only your speaker system and/or your headset - are the only ones enabled. We have often seen surround sound headsets cause this issue.

0

Alright. Deleting the music files in the game folder seemed to fix the issue. Was able to get a 2 hour game in and finish it. Thank you everyone for the help.

0

You could also set the volume for music to 0. this would also stop the music from playing.
(its disabled with 0 volume set)

but nice to hear thats working now 🙂

Log in to reply