client login does not work

today i tried to come back to faf for the first time in a while. i updated the client but there is no login (name and password) fields anymore, just a "log in with browser" button that just does nothing when i click it. i tried uninstalling and reinstalling the clinet but it didn't change anything.

here's a picture:

anybody know what is the problem here? like i said, clicking the "Log in with Browser" button does nothing, and "Play Offline" just gives me this error manage:


Setup default browser on Windows, or change it to Edge

@eternal yeah that was it, for some reason my windows default browser path was broken. i fixed it and the login works now, thanks for the help!

@eternal Sorry, I have the same problem as this user, but on your advice, unlike him, I did not manage to solve the problem, it remained the same as it was.

@voldon which problem exactly

@eternal I will write in detail. I bought the game on Steam, created a profile in it, registered on the FAF website, linked my Steam account, downloaded and installed the client from the official FAF website. But when I start the client there are no lines for filling in the data (Password and Login) There is a button in the center "Authorization", I click but nothing happens, I reinstalled the client, nothing has changed. In general, the problem is the same as that of the user "nick_".

@voldon Client cant detect default browser.

Win+R -> CMD -> copy this -> press enter

if browser is not opens, then you didnt set default browser

If it does not work, you can try to install Chrome or Firefox (reboot PC) and try again.

@eternal I have everything open, without any problems.

@magge I initially had Google Chrome, I already tried the browser recommended by the system, but nothing works.

Have you tried to disable any security software for testing purpose?
Are you 100% sure it is the same error as OP has?

@magge Didn't turn anything off. all system and other antiviruses do not block the client's work in any way.

Could you post client.log file here? CMD -> %appdata%/Forged Alliance Forever/logs

@eternal I don't know how these clients differ from this one that you gave me, but it works.