Gamecrash in every Game

0

Hey Guys
I also got a Problem with my Game.
The Story: I bought a new PC and moved the "old one" from Home to my Office - everything worked fine as it was at home, no crashed, nothing.

Now in the Office, the Game starts crashing in nearly every Game. Sometimes after 3-5 min, sometimes after 20-30 min, but 95% of Games broke up (Game freze completely, i cant do anything...) After a crash i got a new Window next to the Gameicon in Taskbar - "Unhandled Exeption" Debug Error...

I just paste the Gamelog below.

My Setup:

Win 11
3080 on latest driver
i7 8700k

What i just tried:

  • Check hardware after moving (everything fine)
  • Deleted FAF and installed fresh (with a cleaner, so everything was deleted)
  • delete Sup Com (on Steam) and start a new download
  • disable all Mods

Nothing works till now.

Also i found the problem, that i cant close a Game (or just a lobby) normally, i have to use TASK Mngr to stop it - it will freze also.

Hope u can help me, dont know what i should do.

Edit: I also tried to used an extra Program to start the Game in windowed Mode "Definitive Supreme Commander Launcher" a player told me to try it.

Gamelog:
https://pastebin.com/RxqipLBw

0

Update:
https://forums.faforever.com/viewtopic.php?f=3&t=19542#p185585
Found that Post, its nearly the same Problem like mine.

I tryed what the Guy told to try, but it doesnt works by me.
The scan also fount no results...

0

Thank u for ur answer.

I just did what they told in the link - changed from 48000 Hz to 44100 hz.
But it already was on stereo. I dont use headphones, only Monitorspeakers.
I used a Headset before, but mo i dont...

What i dont understand: Why does it happens sometimes after a few min and sometimes after 20-30 min?

1

It's entirely random - which is why is causes so much frustration.

0

The issue is your sound settings. Supreme Commander is very fragile in that way, unfortunately. -

You need to disable surround and/or any sound device that you are not using and/or any FX software that changes your sound.

In the worst case, you need different audio drivers like ASIO4ALL.

If you google the WARN message, there are a ton of people who had the same problem, and it was most of the time related to their sound setting.

https://www.google.com/search?q=XACT%3A+Invalid+arg&oq=XACT%3A+Invalid+arg&aqs=chrome.0.69i59j69i58.152j0j7&sourceid=chrome&ie=UTF-8

0

I changed Sound to stereo and deleted all programs I used for better sound. I also updated Sounddrivers - doesnt works... 😞

1

Here is a post about how you can completely disable all sound:

https://forum.faforever.com/topic/2605/crashes/21?_=1646945847685

The reason for doing that is so you can test whether the game will crash when all sounds are disabled. If your game stops crashing, that means the crashes are definitely caused by sound issues. You will at least know that you are not wasting your time by trying to fix a sound problem.

There are a lot of different things in a computer system that could cause sound problems. It's not just your sound card and your headphones.

0

Also make sure you completely shut down and then start your computer again.

A work of art is never finished, merely abandoned

0

U are right, the Sound is the Problem.
I tryed Arma's Link, it works without sound.

But i dont know what i can change - in my opinion the Sound is set to stereo...

As I used the PC at home (with my Wireless Headset, Steelseries Arctic 9, connected by USB) there was no Problem - now i dont use a Headset, only Monitorspeakers, connected via HDMI, it doesnt works.

I also tryed in Device Manager:

  • disable Realtek Sound
  • disable NVIDIA Sound
    doesnt changed anything.

Then I downloaded the newest Sounddriver from Mainboardpage - nothing changed -.-

0

f57e3f5e-415f-423c-8a12-4e0938040388-image.png

c0f4eb85-0c9d-4528-92e4-ea0b45807539-image.png

68a53ceb-351f-4876-88ea-c559de6b04ee-image.png

2ab2a40e-7e91-45ca-8eed-326e9a0685b5-image.png

also you can try to turn if exist: Dolby atmos and checkboxes in other tabs

0

Thank U Guys for all your Ideas, I tried everything u suggest - but nothing helps to fix the problem till now 😞

I know, i could play without sound, and i dont need most sounds, but some are decent (Acu under fire, Nukelaunches...)

Would it be possible to disable all but those not? (just an Idea)...
If i can say "/nosound" maybe i can say "only XY sounds) ?

0

I doubt it would be possible. You could try a cheap USB sound card. I am surprised ASIO4ALL did not work, that is very odd.

0

I just installed ASIO4ALL, but i cant find a .exe.
There is a Shortcut to ASIO4ALL.ORG on my Desktop and in the installed Folder is next to the Shortcut only one uninstall.exe, asio4all.dll and asio4all64.dll.

Dont know how to use that ...

0

PoMMeS and I were investigating the problem via TeamViewer for quite some time - He has done everything right (double-checked it), but FAF still crashes/freezes.

Works only with /nosound correctly. Windows Event error was not helpful. ASIO4ALL was not useful.

Other games work fine. Tomorrow, he's trying a different USB Headset - and hopefully it will solve the problem. Otherwise, this will get even more mysterious. He uses Windows 11, but FAF should work with it as well.

0

Yes try with a cheap USB Sound Stick like this:
https://www.amazon.de/-/en/Sabrent-External-Adapter-Windows-AU-MMSA/dp/B00IRVQ0F8/ref=sr_1_4

Disable every other sound device. Try without installing drivers for the sound stick.

0

Yes, I run FAF without any problems on exact that PC 2 Weeks ago (with another USB-Headset, Keyboard and Mouse). I dont think that is the Problem, but ill it it tomorrow to be sure.

Dont got any more Ideas...

The only thing i changed (out of Monitor, Headset, Mouse and Keyboard) is, that I installed DATEV on that PC (its a Businessprogramm, that was not that easy to install and update to my base data - so I dont wanna kill Windows and do a clean installation.)

I also tested with an USB-Soundstick (i found here from an older Logitechheadset,Plug&Play) - and I disabled everything else - doesnt works 😞
I got sound, but the game freeze when I closed it...

0

Hey Guys

Ok, it doesnt works - I thought it will work but i doesnt deleted the /nosound from the .exe

I would be happy for every Idea u maybe got...

Thank U very much and have a nice WE!

edit1:

What must I do to run the /nosound via the FAF Launcher?

I tried via the 'Command Line Format for Executable', but what must I insert there? I tested a bunch of things, but without any success.

2

@pommes said in Gamecrash in every Game:

I tried via the 'Command Line Format for Executable', but what must I insert there? I tested a bunch of things, but without any success.

Put this in there:

"%s" /nosound
0

Thank you, I will try it 🙂