Crashes

0

This is fixed in FAF Develop, and therefore fixed once the hotfix it out - thanks for reporting it

A work of art is never finished, merely abandoned

0

Had another crash today, offline Setons 3v3 with 4 Sorian Adaptives and 1 Sorian cheating. A few hours into the game so many units in play including a Paragon.

Sorry no debug, I got the classic GPG crash notification. Also not started through the client so can't confirm its on Devel but I did start a dummy multiplayer game using the devel branch via the client, then used a direct shortcut.

game_15448396.log

0

The log you shared is 42 seconds in - I'm afraid I can't determine the cause with the information you provided. I also can not find the replay in the vault - as that makes sense since you didn't start from the client.

Note that the classic GPG crash notification can point you to the dump file - but I suppose you closed it by now.

A work of art is never finished, merely abandoned

0

Not sure if I should start a new topic or post here, but for the sake of the topic here goes:

1f2a9532-1efa-4b28-bdd2-9c994eb8207a-image.png game_15601005.log
last100lines.txt

System info:

OS Name Microsoft Windows 10 Pro
Version 10.0.19042 Build 19042
Processor Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz, 3696 Mhz, 10 Core(s), 20 Logical Processor(s)
Installed Physical Memory (RAM) 32.0 GB

I was exiting the game. Have had other crashes earlier, but installed the new patch for the FAF client and verified the game files on steam, still not sure its related:
Earlier crash, log file only as the computer rebooted instantaneously.
game_14610360.log

0

@HolyCrap

warning: SND: Error playing cue 5 on bank 1 [explosions] XACT: Invalid arg
Looks like you Soundcard has trouble with XACT
Try to set your soundcard to Stereo only and disable all sound enhancements.
Read here for more information:
https://forum.faforever.com/topic/796/

0

@uveso
Ah, thanks!
Will try that as soon as I'm off work!
Much appreciated!

0

@uveso Configured my output as the topic described. (2channels=stereo i assumed)
Still crashed ~20min into a game. (Tried a Replay first, worked mostly fine, with a crash upon exiting)
Any of these point towards something?

game_15656770.log last100lines2.txt FAF_Crash.PNG

0

hello HolyCrap,

i can still find those errors in your log:

warning: SND: Error playing cue 1 on bank 5 [music] XACT: Invalid arg

Please test if the game crashes if you switch off the sound:

Please make a desktop-shortcut from the file:

    C:\ProgramData\FAForever\bin\ForgedAlliance.exe

Open the shortcut (rightklick->properties) and edit the commandline.
Add "/nosound" at the end. Should looke like this:

    C:\ProgramData\FAForever\bin\ForgedAlliance.exe /nosound

Then start SupCom with the desctop shortcut and make some games.

0

Приветствую, помогите пожалуйста, не могу подключиться к кому-нибудь в игру из за ошибки
java.util.concurrent.CompletionException: NotifiableException(i18nKey=mod.errorUpdatingMods, i18nArgs=[])
at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:314)
at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:319)
at java.base/java.util.concurrent.CompletableFuture$UniAccept.tryFire(CompletableFuture.java:718)
at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
at java.base/java.util.concurrent.CompletableFuture.complete(CompletableFuture.java:2137)
at com.faforever.client.task.CompletableTask.lambda$new$2(CompletableTask.java:19)
at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(CompositeEventHandler.java:86)
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:234)
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(EventHandlerManager.java:191)
at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(BasicEventDispatcher.java:58)
at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(EventDispatchChainImpl.java:114)
at com.sun.javafx.event.EventUtil.fireEventImpl(EventUtil.java:74)
at com.sun.javafx.event.EventUtil.fireEvent(EventUtil.java:54)
at javafx.event.Event.fireEvent(Event.java:198)
at javafx.concurrent.EventHelper.fireEvent(EventHelper.java:219)
at javafx.concurrent.Task.fireEvent(Task.java:1358)
at javafx.concurrent.Task.setState(Task.java:725)
at javafx.concurrent.Task$TaskCallable.lambda$call$1(Task.java:1436)
at com.sun.javafx.application.PlatformImpl.lambda$runLater$10(PlatformImpl.java:428)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
at com.sun.javafx.application.PlatformImpl.lambda$runLater$11(PlatformImpl.java:427)
at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:96)
at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
at com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(WinApplication.java:174)
at java.base/java.lang.Thread.run(Thread.java:832)
Caused by: NotifiableException(i18nKey=mod.errorUpdatingMods, i18nArgs=[])
at com.faforever.client.mod.ModService.writeModStates(ModService.java:375)
at com.faforever.client.mod.ModService.enableSimMods(ModService.java:247)
at com.faforever.client.mod.ModService$$FastClassBySpringCGLIB$$aae9cfd3.invoke(<generated>)
at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:218)
at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept(CglibAopProxy.java:689)
at com.faforever.client.mod.ModService$$EnhancerBySpringCGLIB$$f2aebd0f.enableSimMods(<generated>)
at com.faforever.client.game.GameService.lambda$joinGame$10(GameService.java:324)
at java.base/java.util.concurrent.CompletableFuture$UniAccept.tryFire(CompletableFuture.java:714)
... 22 more
Caused by: java.nio.file.AccessDeniedException: C:\Users\Denis\AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance\Game.prefs
at java.base/sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:89)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:103)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:108)
at java.base/sun.nio.fs.WindowsFileSystemProvider.newByteChannel(WindowsFileSystemProvider.java:235)
at java.base/java.nio.file.spi.FileSystemProvider.newOutputStream(FileSystemProvider.java:478)
at java.base/java.nio.file.Files.newOutputStream(Files.java:224)
at java.base/java.nio.file.Files.write(Files.java:3491)
at java.base/java.nio.file.Files.writeString(Files.java:3707)
at com.faforever.client.mod.ModService.writeModStates(ModService.java:373)
... 29 more

0

FA crashed, but wasn't able to get the info from the pop up without force closing FA. Game crashed two games in a row, while I was building the Czar. I was playing in a 4 player survive map, black sun defense. Once I forced quit out of the game and error window, they were able to continue playing, but I was out of the game. I got the error:

"EXCEPTION_ACCESS_VIOLATION (0xc0000005) at address 0x0050dfd8
attempted to read memory at 0x0000005c"

The unknown symbol portion that followed stated, 0x00423221.

Included Log files below for the two games, in order.

game_16353584.log

game_16353686.log

I appreciate any help!