Nvidia driver performance problem

0

It seems to be a problem with the game not using hardware cursor. I had the exact same issue in Sins of a Solar Empire: Rebellion, and the only way I could fix it was turning on the Use Hardware Cursor option.

0

Yeah it's definitely related to the cursor. If you whip your cursor around you can effectively pause the game. Don't touch it and it seems to run pretty much fine. How annoying.

2

This fix suggested in another thread worked for me when I tried it quickly just now:

Please open the ingame console and type:
d3d_windowscursor

I'll try it in a longer game tonight

0

@Sam-site This worked for me! I could not for the life of me figure out how to open the console using the "Hotbuild Preset"-keybinds, but finally found the button when I switched back to the "Default Preset" -keybinds. Putting in d3d_windowscursor made problem of moving the mouse causing lag go away.

If anyone knows the button to open the console, or where in the settings to change the open console-keybind I would appreciate it.

0

@Sam-site Thanks, that's exactly what was needed. It's basically the command for hardware cursor I think, which is perfect until nVidia fixes their stuff.

2

Laticlave has helpfully made a UI mod titled "Nvidia fix" to correct the driver issue until we can get a proper patch out. Feel free to download it from the vault!

3

There's another way: disable Task manager > Services > NvDisplay.ContainerLocalSystem. This is a better solution then console command as you need to do it once.
But keep in mind that disabling this service will hide the Nvidia Panel tray icon.

UPDATE:
Same thing, but permanent.

  1. Open a Windows Run Dialog (Win + R)
  2. Type in services.msc 7b0a8dce-03b4-47a0-a90e-a6b88ea5ad9a-image.png
  3. Find NVIDIA Display Container LS (Container service for NVIDIA root features). You can press "N" in this window to speed up yourself =]
  4. Right-click on the service and select Properties
  5. Click on the Stop button
  6. Change the Startup type to Disabled
    9ca8764a-343a-4d17-8cb9-b55a1d157cc9-image.png
  7. OK
0

I'm experiencing huge problems here. I've tried to roll back my Nvidia drivers but its not possible for me. The mod in the vault does not work. This game is unplayable for me.

Symptoms:
Extremely laggy mouse movement
Extremely laggy scrolling
Extremely laggy music
When moving the mouse it causes the FPS to drop close to 0

I started noticing this since about the 26th of December. I'm certain i updated drivers then.

I will not be able to play until this is fixed.

1

@SYSTEM_ Could try this someone reported in the discord

Quote from discord "Also can confirm on a RTX2070, stopping this service stop the lagging and stuttering. can also be done midgame"

unknown.png

And unfortunately probably on Nvidia to fix it

0

@Sheikah can u comfirm if these two service are stopped, lag 'll disapear??

0

@Sam-site said in Nvidia driver performance problem:

d3d_windowscursor

thanks it helped and it's terribly inconvenient (

0

I cannot confirm if it helps as I have not done it myself. I just passed along a potential solution someone said they found from the technical-help discord

0

@VertusVi Did you try Laticlave's mod (in the vault, called "NVidia Fix")?

It puts that command in automatically at the start of every match, so you don't have to.

0

It is being reported by quite a few users now that the d3d_windowscursor fix is NOT working for them. The alternative solutions, stopping the Nvidia service, mentioned above, is however solving the issue.

0

@Sprouto that's very odd. What changed? Did Nvidia roll out an even more broken driver?

0

I’ve been having this problem now for a while and am super angry at it. About 20ish minutes into the game it begins to get choppy then soon after unplayable. But only when the mouse is moved. I am forced to reset my pc to play another 20 mins. I’ve tried to turn off the nvidia display stuff in task manager but that doesn’t work. I haven’t tried the other thing in game console because I simply can’t open it

1

@Doge20031 what about the Nvidia Fix UI mod?

0

@Deribus how do I go about installing that? I would be forever in your debt if it fixes the problem until a new driver is released that addresses the situation

0

Look for mod called "nvidia fix" in mod vault in the client and install it.

3

@Deribus Not sure - we've had the d3d_windowscursor command in-line at LOUD for more than a week now, but a couple of days ago, we had some new users showing up that continued to have the problem - using the absolutely latest drivers. The task manager services did the trick, which was good for the users - but the services restart themselves, and not too many users are comfortable with altering core services.

I sincerely hope that this problem gets a proper NVidia resolution, sooner than later, as it's driving people off of FA entirely, especially new users that already have to deal with surround sound issues.