Did last patch break coop?

Red Flag: Ahwassa kills are not counted; Mainframe Tango: the last script never happens.

Yes

queuing with a newbie to show him the beauty of tmm and meeting tagada be like:
https://www.youtube.com/watch?v=yLcRpdZ0Xb0&ab_channel=Tomoko

It appears to work for me and the mission continues

c9a35086-b3c8-4ac5-bb94-289d27738654-image.png

There is an error though:

WARNING: Error running OnStopBeingBuilt script in Entity xsb3202 at 251c8d08: ...ata\faforever\gamedata\lua.nx2\lua\system\import.lua(128): attempt to call method `sub' (a nil value)
         stack traceback:
         	...ata\faforever\gamedata\lua.nx2\lua\system\import.lua(128): in function `import'
         	...ta\lua.nx2\lua\ai\opai\basemanagerplatoonthreads.lua(288): in function `cb'
         	...gramdata\faforever\gamedata\lua.nx2\lua\sim\unit.lua(3660): in function `DoUnitCallbacks'
         	...gramdata\faforever\gamedata\lua.nx2\lua\sim\unit.lua(2184): in function `OnStopBeingBuilt'
         	...data\faforever\gamedata\lua.nx2\lua\defaultunits.lua(1882): in function `OnStopBeingBuilt'
         	...\gamedata\units.nx2\units\xsb3202\xsb3202_script.lua(16): in function <...\gamedata\units.nx2\units\xsb3202\xsb3202_script.lua:15>

error is also described here: https://github.com/FAForever/fa/issues/4710

which is intentional, it appears

A work of art is never finished, merely abandoned

I have a feeling that it broke things here and there. I played with no SIM mods against an AI, and it was sending UEF transports to my base, that were dropping and just staying there unreclaimable, and you can see it on the replay: https://replay.faforever.com/19472348. I also feel like I get more random bugs now.

I need a timestamp

A work of art is never finished, merely abandoned

@jip Just push it to max speed and observe the left part of the map, the wrecks will be accumulating there.

I've watched it and I didn't see anything off beyond the AI being a bit silly: I need a timestamp 🙂

A work of art is never finished, merely abandoned

@jip Timestamp for something that accumulates over the entire game? OK, try 00:30:00.

Hi all,

sorry for pushing this old post. Just came across Mainframe Tango Co-Op mission and it is still not working (tried it two times - the last mission event (EMP for AEON base) is not happening).

You may also guess that there is an issue with this mission by looking into the Co-Op leaderboards where the latest entries for this mission are not younger than October 2022.

Would be nice if someone might have a look and fix this!

Btw. thanks for keeping this game up and alive!

If you didn't do it yet:
Join the Coop-Discord and go to #bug-reporting. There you can state what you said here and if needed can send the logs so the developers of the mission can take a look.
https://discord.gg/6bSA3525SD

I'm redirecting you because I have no idea whether they follow the FAF forum actively.

Not active anymore.

Thank's for the advice!

I joined the discord and searched a little bit through it. It looks like there is already a solution for the issue and it's even fixed: https://github.com/FAForever/faf-coop-maps/issues/401
But it seems like it is not yet within the formal release.

I tested it by fixing the lua script locally as described in the link above and it works for me.