Impossible toImpossibility of authorization in the client. (Problems with the Client)

0

Greetings. I've run into a problem that's looming over me. I downloaded a new client, since the old one was no longer supported, because I had not played for a long time. I downloaded a new one, installed it, and I cannot log in, there are no lines to fill in the data, although I am authorized on the official website. I met this problem before, and the only thing that helped me was people threw off the old-style client, I was able to play with it, but now I can’t even with it, so I deleted it, I decided to download a new one. But the problems of the past won't let me go. 366c7742-3804-4e67-a141-0e1793fc348c-image.png

0

ab63a6c1-93fd-4219-8f55-45709235239d-image.png

Для меня это выглядит так.
Важно что внизу отображается
"окружение main server commended"

Когда нажимаешь "авторизоваться" Страница в браузере не открывается? А если временно поменять браузер по умолчанию? Может сначала открыть браузер а потом открыть фаф и попробовать ещё раз нажать авторизоваться.

Кроме как переустановить не уверен что предложить
Ещё убедись что скачал клиент с faforever.com а не откуда-то ещё

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

With regards to "Environment", I have no options in this line. Well, I downloaded the client 100% from the official site. And when I press the authorization button, nothing happens.

0

Check access to https://content.faforever.com/
It should throw a 403 Forbidden error

0

And we need client log file C:\Users{User}\AppData\Roaming\Forged Alliance Forever\logs

0

@marcspector Yes, it throws the prescribed "403" error.

Here are all the contents in the "Logs" files.
client.log
map-generator.log
irc.log
advanced-ice-adapter.log

0

@VolDon

I see an error:
java.util.concurrent.CompletionException: java.net.SocketTimeoutException: Connect timed out

Client cannot read config from https://content.faforever.com/dfc-config.json

I made a mistake with the link. Check access to https://content.faforever.com/dfc-config.json please.

You should see something like this

28a0a216-ef31-4341-a3f5-0ad437985161-image.png

0

Maybe something prevents the client from reading it. For example, an antivirus or firewall.
Try to run the client as admin

0

@marcspector

I went through the link and saw everything that was thrown off. However, when I run it as administrator, I get this window. when choosing "yes" I go to the client (the Problem does not change), and when "no" the client is disconnected.

04811dd8-6102-4643-93de-0cd0824940f1-image.png

0

@Sheikah Could you help with this?

0

It is just as you said. The client cannot read from https:///content.faforever.com/dfc-config.json So there is some networking issue that is stopping the client.

From the logs it looks like it is some certificate problem but that is really all I can glean from it.

0

@sheikah
And.... How can this be fixed, gentlemen?

0

@sheikah

As I said, I met this problem before, and the only thing that helped me was the old-style client that started and worked, but now it didn’t want to work, apparently from sudden death due to unprofitability.

https://forum.faforever.com/topic/3771/client-login-does-not-work/13?_=1670868637487#

0

Just use VPN to download stuff

0
This post is deleted!
0
This post is deleted!
0

@eternal With a new client or an old one?

0

@paragon_kz
That is not a stack trace from FAF. You have to make sure you download the official client on faforever.com and connect to the main server.

0
This post is deleted!
0
This post is deleted!