FaF freezing after no-rush

Hi Guys,

We had issues trying to play FaF the other night and I was hoping we could maybe get some help. We were playing with a 25 min no-rush game played fine up until the no-rush ended and then the whole thing froze for all players. We tried this a few times with the same result and then we tried a game with no-rush off and that seemed fine (We only played for 5 mins to confirm as it was getting late at that point). I'm not really too sure what could be up here but I suppose my guess would be mods. We had the following enabled:

Total Mayhem (137.00)

Ai-Uvesoo (100.00)

Supreme score board (6.0)

Blackops FAF unleashed (19.0)

BrewLanadditional unit (2.0)
T2 T3 Storage FAF rebalanced (9.1)

I've played with these in single player fine so I'm usure why it was causing an issue in multiplayer. The logs are below but they don't contain much:

debug: Gametime: 00:24:00 --- Unit: 1109 --- Platoon: 84 --- FPS: 60 --- Memory: 494.9M / 509.6M --- Speed: +0 / +0 --- SimSpeed: 98% ( 60 Game = 60 System Seconds )

debug: Entity: 08827 --- Prop: 02965 --- CScriptObject: 18530 --- CTask: 13328 --- CTaskThread: 13004 --- CLuaTask: 00448 --- CDecalHandle: 01808 --- ReconBlip: 01147

debug: Current gametime: 00:24:30

info: Hooked /lua/kirvesweapons.lua with /mods/blackopsfaf-unleashed/hook/lua/kirvesweapons.lua

info: Hooked /lua/kirvesbeams.lua with /mods/blackopsfaf-unleashed/hook/lua/kirvesbeams.lua

debug: Current gametime: 00:25:00

debug: Gametime: 00:25:00 --- Unit: 1182 --- Platoon: 79 --- FPS: 43 --- Memory: 476.0M / 509.8M --- Speed: +0 / +0 --- SimSpeed: 98% ( 60 Game = 60 System Seconds )

debug: Entity: 08948 --- Prop: 02965 --- CScriptObject: 19197 --- CTask: 13829 --- CTaskThread: 13511 --- CLuaTask: 00448 --- CDecalHandle: 01896 --- ReconBlip: 01226

info: ren_oblivion true

info: ren_ui false

info: send Ptr: 97E40002

info: send Ptr: 85D00002

info: send Ptr: 9EC40002

info: send Ptr: A0C40002

info: send Ptr: 97E40002

info: recv Ptr: 97E40002

info: recv Ptr: 9EC40002

info: recv Ptr: A0C40002

info: recv Ptr: 85D00002

info: Callback packet received, exit sync is over

Any ideas whats causing the issue?

No idea - I'll see if I can reproduce it.

A work of art is never finished, merely abandoned


Deribus already posted me this link 3 says ago.

I tested no rush with Total Mayhem, Black Ops and my AI, but did not found any error or crashes.
Still possible that the storage mod or Brew LAN's units can have an side effect.

@howski I've experienced this. My rough estimate of the problem is 1) the AI players have overlapping no rush zones which can cause this 2) certain mods cause this. I haven't invested the time to validate these.

Hi All,

Thanks for your replies.

@Jip thanks for your efforts it happened each time when we were on but too be fair I tested a simular setup single player with no issue

@Uveso Yeah thats me oon Reddit. Didn't realise someone had taken a look - other than unit/mod incompatability any ideas?

@Defiant Thats a possibility as the slots were side by side - I'll spread them out next time

@Howski ,

i tested Total Mayhem, AI-Uveso and Blackops FAF unleashed in a no rush game today.
Got no errors.

Could you test if Supreme score board, BrewLanadditional unit or T2 T3 Storage FAF rebalanced
are causing the crash ?

Also, could you please post the full game.log, so we can see all AI settings, the map you played and so on.
(upload it to pastebin.com and only post the link here)

btw, i only test on the FAF develop version of the game, no clue how the release version is working.
(if you host the next game select the FAF DEV version please)

@Uveso Forgive my ignorance but where are the full logs? I thought that was it!

We'll all be on tomorrownight so I'll report back

C:\Users\%username%\AppData\Roaming\Forged Alliance Forever\logs