Game crashes about 15 mins in

0

Hello!

My game exits with a crash without fail about 15-20 minutes in. FWIW, it also crashes every time I "exit to windows." I can provide one of those logs if it helps --- the log below is the crash during gameplay.

I looked into the "sound set to stereo" solution and I think it's all set up correctly so I'm reaching out here for help. This happens in co-op (even solo) but also during custom matches. I haven't tried matchmaking yet. The game appears to run great right up until it crashes. I don't notice any obvious slowdowns at least. I tried removing the first processor from "core affinity". I think that got me a few more minutes before crashing, but tbh it could be my imagination. Any help is appreciated!

I used to play as ShoemakerLevy back in the GPG days and I'll be so happy if anyone can help me get the game running.

Thanks to anyone who has the time to help me solve this one!

game_16994511.log

Best,
Zach

0

The core affinity should have nothing to do with it.

  1. Try to run with /nosound command once to really blame the sound card. Watch a 1+ hour replay with 10+ speed and see if it crashes without sound. Howto: FAF options: https://i.imgur.com/DIy6WKO.png

  2. After that: Just to be safe: Reinstall Supreme Commander from Steam and reinstall FAF, removing any leftover files before (You can use Revo Uninstaller for that, free software).

  3. Disable (right click → disable) any sound device, so you have only one active (you can reactivate them later again when it works). Example: In my case, I need to deactivate everything except Focusrite (my USB Sound card) https://i.imgur.com/4cWixCF.png

  4. If it still does not run, get any cheap USB sound card and disable your on-board audio in BIOS, then try again, only with your new USB sound card.

0

You have XACT errors; please search the forum and you'll find all the possible solutions. The faqs are a good starting point (just setting audio to stereo might not be enough).

0

Thanks all! Will try and reply. Appreciate ya.

0

"Nosound" fixed the issues. It's unclear though which device causes the issues after going through them. I couldn't get the replays to crash after going one by one with each device, but co-op still crashes. Would it make any difference to troubleshoot in custom matches instead? Thanks!

0

@karlmarx420 said in Game crashes about 15 mins in:

Would it make any difference to troubleshoot in custom matches instead?

I guess, it makes no difference. But the replay with x10 is the fastest way to trigger the error.