Unable to install FAF Client 1.4.0, ucrtbase.dll

0

Problem: Unable to install FAF client 1.4.0
Extracting Files..
ucrtbase.dll

Error Message:
ucrtbase.dll Could not create this file. Shall I try again?

Trying again doesn't work
Attempted a reboot

Running as administrator
Edition: Windows 10 Home 64-bit
Version 20H2
OS Build: 19042.804
Experience: Windows Feature Experience Pack 120.2212.551.0

Is there a way to extract more information from the error, so I can figure out the problem?
Anyone else encountered similar issues on this?

0

Open installer as Administrator

0

@Eternal

Same result

0

@kaprob Do u have Microsoft Visual C++ 2005-2019 ?
old ones is not necessary but... who knows

0

Yes I have both x86 and x64, looks like I am on version 14.24.28127.4
a quick google shows a 14.28 version so I'll try an update

0

@Eternal
after an upgrade of visual c++ 2019 to 14.28 same issue persists unfortunately

0

@kaprob Python client 0.19.13 < install this client then, i have no idea.

0

@Eternal
Is that a alpha/beta version of FAF client?

0

Old client, that is lighter and faster than current FAF client

0

@Eternal

I did try your idea of installing older clients from 1.4 down to 1.0 but all have the same error 😞

So 0.19 has installed and I've linked my steam account etc..
but I'm unable to launch a game 😞

Traceback (most recent call last):
File "src\games\hostgamewidget.py", line 71, in _launch_game
File "src\fa\check.py", line 133, in check
File "src\fa\updater.py", line 170, in run
File "src\fa\updater.py", line 524, in doUpdate
File "src\fa\updater.py", line 540, in failureDialog
Exception: Update started at 2021-02-22 16:06:26
Using appdata: C:\ProgramData\FAForever
Connected to update server at 2021-02-22 16:06:26
EXCEPTION: [Errno 13] Permission denied: 'C:\ProgramData\FAForever\bin\DbgHelp.dll'

Runtime info:

FAF Username: kaprob
FAF Version: 0.19.13+60
FAF Environment: production
FAF Directory: C:\ProgramData\FAForever
FA Path: : e:\steam\SteamApps\common\Supreme Commander Forged Alliance
Home Directory: C:/Users/Admin2/Documents
Platform: Windows-10-10.0.19041
Uname: uname_result(system='Windows', node='RobsPC', release='10', version='10.0.19041', machine='AMD64', processor='Intel64 Family 6 Model 63 Stepping 2, GenuineIntel')

0

@kaprob it appears this is just an overall permissions error for your account. You can try installing either client in a different location that does not require admin permissions. OR check the permissions on your file system and FAF install.

0

@Sheikah
Unfortunately I'm clueless at this point, I'm installing as admin with an admin account and I've tried installing the FAF client under documents in the case it was having issues with Program Files but no luck

0

You shouldn't install as an admin. Can you check permissions on the FAForever folder in ProgramData (hidden folder NOT Program Files) or delete that folder before you reinstall?

0

@Reckless_Charger
had a look and all is fine, should have full permissions

1

@kaprob My bad, version of the client i have sent to you is bugged.
Try this one 0.19.11

0

@Eternal
This version install and updates the game 🙂 was able to playa quick game against AI successfully
Thanks for the help all.
Hopefully a developer will later be able to tell me how to debug the ucrtbase.dll issue so no one else has this problem

Log in to reply