Linux Support


@drpatrickstar Yes both, and neither worked.

I'm not sure how to approach this anymore. I've tried using the old python client, tried getting a friends files and just running the game by itself. I can't figure it out 😞


Weird, Lutris works super well for me, despite nothing else working.
Can you tell me at what point Lutris install breaks down?


@Gzack I have no idea what you're doing or why you're having this experience.
using FAF on linux is easy. you just do this:

(in this video where java 14 is mentioned just do java 17 instead) :


Hi guys, I am trying to install Faf on linux and running into an issue with protontricks (step 5 of I am able to install all the programs, and the protontricks folder populates, however, when trying to run ./protontricks 9420 dlls d3dx9 there is no executable file for it to run ('file or directory not found').

Aside from this, I am able to follow the installation guide, create an FA profile, and set up faf etc. The only issue is that FA gives me a black/frozen screen both in steam and FAF, presumably because I couldn't complete step 5.

I am running Ubuntu 20.0.4 with OpenJDK 17. So far I have tried proton experimental, 5.0, and 7.0-2. I have tried installing protontricks first and installing steam FA first. All other steam games and all features of the faf client are working well. Has anyone else had any experience with this?

edit: does graphics card matter? I am using Mesa Intel® UHD Graphics 620 (KBL GT2) on my laptop.


@evan_ For graphics cards for Linux gaming AMD is the best because their drivers are opensource. You can get external GPU enclosures like the Razer Core X though it would depend on how mobile you are.



Hi i installed FAF today

with some guides

and this worked

heres my guide

i had major problems with java environment
and the essential run script and essential faf.desktop run script

now its working like a charme


Thank you both, I'll check out that guide and see how it goes.



t seems to me you are typing

./protontricks 9420 dlls d3dx9

into the terminal

but you should type

protontricks 9420 dlls d3dx9

into the terminal


Hi everyone. I was having issues with fonts not rendering in the launcher on archlinux. The issue was fixed by installing Microsoft's fonts using the package "tts-ms-fonts" from the AUR.

Just posting it here in case anyone else has the same issue in the future


I did a lot of playing around with linux faf today and i got 2 notable bits of info to share will everyone.

  1. If you (like me) have extreme stuttering during the launch animation and the score screen, i have found a way to remove it (at the cost of some looks). To remove it u need to take this command and add /nomovie to the end of the command after the %s. This removes all videos/movies from the game.

  2. Jip will be putting out a video on how to setup a development environment for FA. I went through and created a script that would allow us linux users to contribute as well. It will be located here as soon as my pr is accepted