FPS abruptly becomes like 10


Sometimes on dualgaps aproximately on 10 min of the game my FPS abruptly lower from 144 to 5-10. Alt+Tab doesn't help. I tried to reinstall FAF but also no effect. Who did struggle with similar situation?

this is not:

  • UI mods
  • corrupted files (steam validating successfully done)

I'm experiencing same issue. Don't know why but probably due to new process affinity mask.

My UI Mods

Does it also happen when there are no mods, including UI mods? I personally use no UI mods and I have no problems

A work of art is never finished, merely abandoned

@jip I have some UI mods installed, but usually I play on the public servers with no mods. Nevertheless, I just deleted all my mods and I will try again without them.

@jip No, unfortunately deleting UI mods have no effect as well. Very next game and once again approximately at 10 min of the match FPS has died. Maybe log file will provide some information about that issue?

Logs are always welcome. When did this behavior start? Could you check the task manager next time it happens, report back the CPU usage and the RAM usage?

@Azath0th if you think it is the affinity changes then you can check this by reverting them when it happens.

A work of art is never finished, merely abandoned

Few years ago I had similar issues with a specific motherboard when using Win 10, Win 7 was fine.
I tried changing everything else besides the motherboard itself (CPU, RAM, GPU, Fresh OS install, drivers, BIOS etc.), only going back to Win 7 fixed it.

First few minutes were fine with the occasional FPS drop, but 10-15 min in it usually started dropping to single digits now and then, with 30min+ completely unplayable.

So I'd start with trying the steam version of the game, does it work there or not?

Then ofcourse the usual issue finding:

  • Temps? Other resource usage oddities?
  • Fresh install of base game + FAF (also deletion of gamedata folder and make sure no mods)
  • Drivers?
  • BIOS update?
  • Any other applications with similar issues?
  • Fresh OS
  • after this mostly hardware debugging/incompatibility debugging left

Just a matter of narrowing it down one by one by eliminating possible problem sources.

Just throwing it out there: have you tried disabling vsync in game?