Can't star\join game

Nothin happend when I press to create the game and when I tried to join it show these errors:
Client Version: 2023.1.1
java.lang.Error: java.nio.charset.UnmappableCharacterException: Input length = 2
at java.base/java.lang.String.decodeWithDecoder(
at java.base/java.lang.String.newStringNoRepl1(
at java.base/java.lang.String.newStringNoRepl(
at java.base/java.lang.System$2.newStringNoRepl(
at java.base/java.nio.file.Files.readString(
at com.faforever.client.mod.ModService.readPreferencesFile(
at com.faforever.client.mod.ModService.readActiveMods(
at com.faforever.client.mod.ModService.enableSimMods(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept(
at com.faforever.client.mod.ModService$$SpringCGLIB$$0.enableSimMods(<generated>)
at java.base/java.util.concurrent.CompletableFuture$UniRun.tryFire(
at java.base/java.util.concurrent.CompletableFuture.postComplete(
at java.base/java.util.concurrent.CompletableFuture.complete(
at com.faforever.client.task.CompletableTask.lambda$new$2(
at com.sun.javafx.event.CompositeEventHandler.dispatchBubblingEvent(
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(
at com.sun.javafx.event.EventHandlerManager.dispatchBubblingEvent(
at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(
at com.sun.javafx.event.EventDispatchChainImpl.dispatchEvent(
at com.sun.javafx.event.EventUtil.fireEventImpl(
at com.sun.javafx.event.EventUtil.fireEvent(
at javafx.event.Event.fireEvent(
at javafx.concurrent.EventHelper.fireEvent(
at javafx.concurrent.Task.fireEvent(
at javafx.concurrent.Task.setState(
at javafx.concurrent.Task$TaskCallable.lambda$call$1(
at com.sun.javafx.application.PlatformImpl.lambda$runLater$10(
at java.base/
at com.sun.javafx.application.PlatformImpl.lambda$runLater$11(
at Method)
at java.base/
Caused by: java.nio.charset.UnmappableCharacterException: Input length = 2
at java.base/java.nio.charset.CoderResult.throwException(
at java.base/java.lang.String.decodeWithDecoder(
... 38 more

I am getting the exact same error when trying to start/join a customer game. I can join matchmaking and coop just fine. I am on Windows 11. I installed the newest Java, updated windows. Uninstalled and reinstalled FAF twice. Tried turning ICE on and off. Nothing is working.

Can you share your Game.prefs file? Thanks in advance

having same error whats happening

Okay, I deleted this file and things started to work. Anyway, thank you for your time.

Thanks for providing the file. It looks like it has issues for exactly this line under the LobbyPresets:

PlayerName = 'Tengelin (TargetDrone (ИИ: норма))',

If I remove that, it works. The rest needs some further testing why it happens.

Having the same issue, seems to be issue of client game.prefs reader.

“Be a yardstick of quality. Some people aren’t used to an environment where excellence is expected.”
— Steve Jobs.
My UI Mods

Release 2023.1.2 was just created which will hopefully resolve this issue update and let us know

I just tryed to make a game but it will not let me or join but i can play co op no problem