Open Lobby with any MOD and it gets this error, please help

Hello there, I hope u all had a nice day.

I have this error since 2 weeks and can't get a fix for it.
I did download another MOD's, same error
Did remove the MOD folder, still the same error after downloading and using any MOD

I cant even use a simple MOD like "no shake" or "Uveso", it posts allways the same error, i hope here is someone who could help me, thanks in advance

```java.util.concurrent.CompletionException: NotifiableException(i18nKey=mod.errorUpdatingMods, i18nArgs=[])
	at org.springframework.aop.interceptor.AsyncExecutionAspectSupport.lambda$doSubmit$3(
	at java.base/java.util.concurrent.CompletableFuture$
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: NotifiableException(i18nKey=mod.errorUpdatingMods, i18nArgs=[])
	at com.faforever.client.mod.ModService.writeActiveMods(
	at com.faforever.client.mod.ModService.overrideActivatedMods(
	at com.faforever.client.mod.ModService.updateAndActivateModVersions(
	at com.faforever.client.mod.ModService$$FastClassBySpringCGLIB$$aae9cfd3.invoke(<generated>)
	at org.springframework.cglib.proxy.MethodProxy.invoke(
	at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.invokeJoinpoint(
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(
	at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.proceed(
	at org.springframework.aop.interceptor.AsyncExecutionInterceptor.lambda$invoke$0(
	at org.springframework.aop.interceptor.AsyncExecutionAspectSupport.lambda$doSubmit$3(
	... 4 more
Caused by: java.nio.charset.MalformedInputException: Input length = 1
	at java.base/java.lang.String.throwMalformed(
	at java.base/java.lang.String.decodeUTF8_UTF16(
	at java.base/java.lang.String.newStringUTF8NoRepl(
	at java.base/java.lang.String.newStringNoRepl1(
	at java.base/java.lang.String.newStringNoRepl(
	at java.base/java.lang.System$2.newStringNoRepl(
	at java.base/java.nio.file.Files.readString(
	at com.faforever.client.mod.ModService.writeActiveMods(
	... 13 more

Try renaming or removing your preference file. You can find it via the bar menu (top left) in the client.

A work of art is never finished, merely abandoned

Hey there, thanks for response

  • Deleted all MOD's
  • Did a clean new install with the Steam client

Still the same error.

I will later make a clean new install from FAF, thats the last thing i think i can do

That doesn't clear your preference file. Try renaming or removing that.

A work of art is never finished, merely abandoned

I deleted the "game.prefs" file, still the same error 😕

YE now i can play

->did a driver update + an clean install from faf and a fresh download in steam
-> deleted all mods and the "game.prefs" file

Thanks alot for help ❤