The game is "paused"


When we try to play with a friend, a bug occurs after a random amount of time. The game seems to pause. That is, you can select units, watch their checkpoints, and so on. However, the game cannot continue. We tried turning mods on and off, turning the pause mode on and off with the button. We don't have any more ideas.
I didn't see any errors in the logs, maybe you can help me. These are just some logs game_17858968 my.log game_17801583 my.log game_17801583 friend.log game_17796551 my.log game_17796551 friend.log taken by chance.


There are a ton of error messages in those logs:

Bunch of this:

Warning: Error running lua script: ...mdata\faforever\gamedata\lua.nx2\lua\terranunits.lua(535): attempt to call method `SetRate' (a nil value)
         stack traceback:
         	...mdata\faforever\gamedata\lua.nx2\lua\terranunits.lua(535): in function `OnTransportDetach'
         	...mdata\faforever\gamedata\lua.nx2\lua\terranunits.lua(556): in function `InitializeTower'
         	...mdata\faforever\gamedata\lua.nx2\lua\terranunits.lua(568): in function <...mdata\faforever\gamedata\lua.nx2\lua\terranunits.lua:564>


warning: Error running OnStopBeingBuilt script in Entity xeb0204 at 28248208: ...\gamedata\units.nx2\units\xeb0204\xeb0204_script.lua(19): attempt to call method `SetRate' (a nil value)
         stack traceback:
         	...\gamedata\units.nx2\units\xeb0204\xeb0204_script.lua(19): in function <...\gamedata\units.nx2\units\xeb0204\xeb0204_script.lua:13>


warning: Unknown DirectSound speaker configuration 8. Defaulting to Stereo.

And probably more.

Possible fixes:

  1. Make sure your sound card is stereo only, not 8 channel something.

  2. Disable all mods, recreate the error for at least two different maps and post again the logs, please.

  3. If without any mods you still get an error, try the following for you and your friend, if nobody has a better idea:

@magge said:

Possible fix:

Uninstall FAF and Supreme Commander completely and remove any leftover files, so we can begin with a 100% working environment.

Make sure no leftover files are in: (Path may be different, if you have the GOG version, or you have selected a different installation path.)

C:\Program Files (x86)\Steam\steamapps\common\Supreme Commander Forged Alliance

C:\Users\%username%\Documents\My Games\Gas Powered Games\Supreme Commander Forged Alliance


%LOCALAPPDATA%\Gas Powered Games\Supreme Commander Forged Alliance\

Install the latest release from FAF from here:
Install Supreme Commander via Steam or GOG


Does this happen when there are a huge amount of units in the game?

As you say, the game will become unresponsive when there are too many of them on the map-sound and music will still work and you can select units, but most if not all of them won't follow new orders (air is generally an exception even in that situation).

If that's your issue, I can only recommend lowering the unit cap; that said, it's entirely possible that those errors might point to another problem altogether.