Supreme Commander (vanilla) terrible stutter with ~200 units on map

0

Hey guys, this is a question for the vanilla SupCom, sorry if this isn't the right place.

I picked this game up recently and had been enjoying it a lot until I came across this issue during the first mission with the red faction. At some point the game stutters completely as you can see in the video. No matter what I tried nothing has helped; reloading, restarting the PC, changing compatibility settings, changing resolution, switching to windowed, vsync on/off. Changing graphics doesn't seem to make any difference either, the stutter is the same on the lowest settings as well. I did come across the 'nvidia fix' but my GPU is AMD.

My specs are:

  • R5 3600
  • RX 5700XT
  • X470
  • 16GB DDR4 3000MHz RAM
  • SSD (both OS and game)
  • Win10

Is it just because I have too many units?

0

I do not know a solution.

We do have the vanilla campaign too, here on FAF.

A work of art is never finished, merely abandoned

0

@adreno349 Do you have memory overclocking turned on in the bios? xmp/docp/eocp
and is precision boost overdrive turned on?

0

very hard to understand what is happening on the video...
does issue only appear when you move your mouse cursor? ( i could not understand that from the video caues you always move it on the video)
does it only happen when you load the game? it looked like there was no lag until you loaded the game... so it is weird
difference between 100 and 200 units is not big

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

okay i looked again and i have no idea what is happening. maybe you can try windowed mode and try to bring up task manager and see if game loads 1-2 CPU cores or GPU on 100%

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

@jip That sounds great, how do I go by doing that? I have FA and the FAF client installed.
Edit: @Photek filled me in on how to do that, for anyone else who might be interested:
To play FA campaign via FAF
1- open the client
2- open play tab
3- open co-op tab
4- pick appropriate campaign mission
5- Optional - Set password to make your game private
6- set title
7- Host your game 🙂

@thecore Yeah I do have XMP turned on, nothing else though.

@ZLO The stutter in the video is independent of mouse movement or zoom level. I'm flicking the mouse around to show that it's not the recording that's stuck but the game. No spikes in CPU or GPU temp/utilization.
I tested running a skirmish map and spawning as many units as I could and I got to 400+ units with no issue whatsoever. I don't know what to say really lol.
Continued playing the campaign with no issue though.