FAF is awesome, but I'm having some issues

0

First of all, I love FAF, it makes the game so much better!

I am trying to play the campaigns through the coop mode in FAF. However the client downloads the coop game files (various .nx2 files) EXTREMELY slowly.

To start to play the first UEF mission took 4-5 hours, and when I went to play the second mission, it seems to have started downloading the same files again! As I write this its already been several hours, again with no end in sight. (It would be helpful to have a download meter so I know at least how long its going to take)

Am I doing something wrong? Is there an alternative way to do this?

I've considered just playing vanilla SUPCOM without FAF, but that would mean playing without the FAF, with its hotkeys and all the many improvements it comes with.

I have tried the "play offline" option available when FAF is loading up, but for campaign this appears to be broken, as objectives in the game don't seem to register and the mission simply never ends. (also, there does not seem to be anyway to play the original, non-FA SUPCOM missions either? Or have I missed something here?)

Please help! I really want to play this game, but its currently not feasible.

0

Hi there!

Unfortunately, you decided to start playing the coop missions at the wrong time: the latest patch broke them. I'm sure this will get fixed as soon as possible, but for now you are out of luck unless you manage to download an older faf version (perhaps by running an older replay? I'm sure there's a way).

As for the slow download speed, that's a known issue and it's being worked on, but for now you might find it easier to just download them directly from github:

https://github.com/FAForever/faf-coop-maps

I'm sure one the devs will eventually see this post and give you more information/tips!

0

@Sheikah is this client related?

A work of art is never finished, merely abandoned

0

This is just the normal download issues where occasionally the download speed is slow because we only have one server serving all content. And with regards to offline play it does not support coop yet.

With regard to the coop patch I have no knowledge of that.

0

Try vanilla campaign withfaf patch
%programdata%\faforever\bin - launch forgedalliance.exe

0

Thanks for the help. The download part seems to be working better now. Yes the coop is broken in several ways, but its just playable (using youtube to fill in the cutscenes and bits the game is missing.) Looking forward to playing it properly when its fixed!