Desync on all replays and games with Windows 11 Arm on M1 Max Apple

1

Hi,

I'm running SupCom FA & FAF on Windows 11 ARM on Apple MacbookPro M1 Max in Parallels 17.1. The game runs good (298 cpu score, ~90 fps), but I've noticed that all replays I've tried desync the first second after game starts. This happens also if I join a PVP game. The full game can be viewed on FAF replay, I'm user "malu5531": https://replay.faforever.com/15627000 (needles to say, the game probably looks quite different when others view it compared to when I played it).

I've tried to adjust emulation settings, parallel settings, etc, but not closer to a solution. I'm running Windows 11 Arm release 22489 with FAF Arm emulation setting set to "Safe Emulation".

I've posted a video of the game running on youtube:
https://www.youtube.com/watch?v=ukKOy20BwBk

I attach client.log and game_11612043.log with details on the error when I try to view the following replay: https://replay.faforever.com/11612043

I guess the issue may be some patch / mod not loading correctly since the desync happens immediately. Any ideas what I can try to fix this and/or is there any more information or detailed logs needed for troubleshooting?

Attachments: game_11612043.log client.log

2

If you are lucky this is a fixable issue. But I remember the original lead engineer saying in an interview that they had some issues with some hardware not being deterministic with certain operations (hardware accelerated sine/cosine calculation was the issue if I remember correctly). If the emulator is partially non deterministic then there is nothing FAF can do.

0

@malu5531,

the game has a checksum that is calculated based on the Sim state.
If this checksum is not equal to host/client/replay then you will get a desync.

That means your game does not execute the same commands or has not the same data then other games.
This happens when you have different game or modfiles than your host/client or replay.

Have in mind there can be several mod folders.
Mods can also be installed as *.SCD archive inside the gamedata folder.

After viewing your log, i would suggest:

  1. Go to steam and make a filecheck to validate your base game files.
  2. go to C:\ProgramData\FAForever\gamedata\ and delete everything inside the gamedata folder.
  3. Update the FAF client and downlaod the latest FAF game version (host a game alone to update the files)

Then try again.
(without mods please)