Nvidia driver performance problem

Unfortunately none of the given fixes work for me, does anyone have further ideas?
I can freeze the game simply by moving my mouse. This happens in vanilla FA as well as FAF, in the intros, main menu and in-game.
I've tried:

  • Clean installs of driver versions 441.41, 442.74, 457.30, and 461.09.
  • Running DDU, then clean installing 441.41
  • Disabling the NVIDIA Display Container LS service
  • d3d_WindowsCursor on/off
  • The NVIDIA fix mod
  • Setting FPS cap to 60 in NVIDIA Control Panel
  • Reducing mouse polling rate from 1000Hz to 125Hz
  • Vsync & AA on/off
  • Various resolutions
  • Windowed mode
  • An ancient Dell mouse instead of my G502
  • Disabling my secondary monitor

My PC: (In case it helps)
RTX 2080S, 9900k, 32GB DDR4-3200
Game owned through Steam

@ThaPear. you clearly have remnants of the driver sticking around despite your "clean installs" of the nvidia driver

You can probably prove this if you have an extra hard drive or space on your hard drive, just install a new windows there for testing, put driver 450 I don't think you need to go much lower. it should work then. if it does, you might want to just transfer all your files and use that new windows install instead.

Hi all, I had a previous update 460.89 (my friend was on an older version) and I was having major packet loss in a 2v2 battle with my friend after just installing FAF for the first time in years as host or with my friend hosting, then saw the notice about GeForce driver issue. I was fine when zoomed in not moving and then when the mouse moved or I was scrolling out all the way and playing we would get constant jitters from the packet loss on my end, confirmed this with F11 and could see I was behind 5. I just updated to 461.09 and the issue was resolved for me and our game was perfectly smooth so I believe this is now fixed in the current Nvidia patch as we just played another 2v2 with no issues at all and increased the speed to x10 with me zooming around like crazy with no jitters at all or packet loss.

461.09 fixed it for me, hope it does for you guys too ❤

@mdcobra yes d3d

@nine2 said in Nvidia driver performance problem:

Edit: Laticlave has helpfully made a UI mod titled "Nvidia fix" to correct the driver issue until we can get a proper patch out. Feel free to download it from the vault!

(Send by Deribus on discord)

We've received reports that the newest NVIDIA driver update, version 460.79, can cause significant performance issues in FAF. It's highly recommended to avoid updating to this driver or roll back if you have already done so.

We don't have much information as of yet, and will keep you updated if there are any changes or fixes.

If you need help rolling back your driver, please check the pins in the #technical-help channel

The cursor problem still exists with driver 461.09 for me,but on the plus side the nvidia fix mod works for me going to try a proper game with poeple now,so far so good.

NVIDIA GeForce driver 461.33【HotFix】

The hotfix addresses the following issues:
•Adobe Premiere Pro may freeze when using Mercury Playback Engine GPU Acceleration (CUDA) [3230997/200686504]
•[461.09] NVIDIA Broadcast Camera filter may hang. [200691869]
•[Steam VR game]: Stuttering and lagging occur upon launching a game (Without using any Hardware monitoring tool). [3152190]
•[Detroit: Become Human]: The game randomly crashes. [3203114]
•[NVENC] Colors of webcam video image on receiving end of Zoom may appear incorrect [3205912]
•[Assassin's Creed Valhalla] Game may randomly crash after extended gameplay [200679654]
•[X4: Foundations][Vulkan]: The game may crash on GeForce RTX 30 series GPUs. [3220107]
•[X4: Foundations][Vulkan]: HUD in the game is broken. [3169099]

GeForce RTX 30 Series:
GeForce RTX 3090, GeForce RTX 3080, 3070, 3060 Ti
GeForce RTX 20 Series:
GeForce RTX 2080 Ti, GeForce RTX 2080 (Super), GeForce RTX 2070 (Super), GeForce 2060 (Super), Titan RTX
GeForce 16 Series:

GeForce GTX 1660 SUPER/Ti, GeForce GTX 1660, GeForce GTX 1650, GeForce GTX 1650 Super
GeForce 10 Series
GeForce GTX 1080 Ti, GeForce GTX 1080, GeForce GTX 1070 Ti, GeForce GTX 1070, GeForce GTX 1660 Ti, GeForce GTX 1060, GeForce GTX 1650, GeForce GTX 1050 Ti, GeForce GTX 1050, GeForce GT 1030
GeForce 900 Series
GeForce GTX 980 Ti, GeForce GTX 980, GeForce GTX 970, GeForce GTX 960, GeForce GTX 950
GeForce 700 Series
GeForce GTX 780 Ti, GeForce GTX 780, GeForce GTX 770, GeForce GTX 760, GeForce GTX 760 Ti (OEM), GeForce GTX 750 Ti, GeForce GTX 750, GeForce GTX 745, GeForce GT 740, GeForce GT 730, GeForce GT 720, GeForce GT 710, GeForce GT 705
GeForce 600 Series
GeForce GTX 690, GeForce GTX 680, GeForce GTX 670, GeForce GTX 660 Ti, GeForce GTX 660, GeForce GTX 650 Ti BOOST, GeForce GTX 650 Ti, GeForce GTX 650, GeForce GTX 645, GeForce GT 645, GeForce GT 640, GeForce GT 635, GeForce GT 630, GeForce GT 620, GeForce GT 610, GeForce 605

Windows 10 64-bit Standard Driver - https://international-gfe.download.nvidia.com/Windows/461.33hf/461.33-desktop-notebook-win10-64bit-international.hf.exe

Windows 10 64-bit DCH Driver - https://international-gfe.download.nvidia.com/Windows/461.33hf/461.33-desktop-notebook-win10-64bit-international-dch.hf.exe

Working great. With nvidiafix mod

This post is deleted!

Version 461.40 works good with nvidia fix mod; Tested it with another guy on a 2v2 map with cheats for a big airbattle.
No lags, almost no stuttering, stuttering free scrolling; Cursor is working too and is not flickering.
The only thing I noticed is screen flickering sometimes but barely noticable. It did not affect the overall gaming performance.

Also make sure that the mod is activated when you create a new game. You can also check that in game under Options -> Gameinfo

Ryzen 9 5900x
RTX 3080
Nvidiadriver: 461.40

For the life of me, I cannot find the 'nvidiafix' mod.

@shultz13 try "Nvidia fix"

@shultz13 said in Nvidia driver performance problem:

For the life of me, I cannot find the 'nvidiafix' mod.

If you have the most recent version of the client (should be version 1.4) there is a tab called "mods"

If you have an older version of the client, you need to click on "vault" and then click on "mods"

That takes you to the mod vault.

There should be a section called "Recommended UI Mods." The NVidia Fix mod is in that section, it looks like #7.

You can also search for the mod by name. Search for the word "Nvidia" and it will come up. Just search for all mods with "Nvidia" in the name (using the search tools) and it will come up.

The exact name of the mod is "Nvidia fix" (two separate words).

Does anyone have a non-FAF version of the nvidia fix mod for both FA and vanilla SupCom? I've just reinstalled the games to play through the campaigns and it's impossible to play with this bug.

@ShEsHy Have you tried the FAF Nvidia Fix mod with other versions of Supreme Commander? I think it would work with them. All it does is put a single console command in at the start of every match. That probably is 100% compatible with other flavors of SupCom.

You can also enter the console command yourself, just press ` (tilde key) to open the console, then type it in. The command is:


You only have to do that one time per match. But you have to do it every time, which is why the mod is more convenient, because it does it for you.

I don't have FAF installed, that's why I asked for non-FAF versions (don't think FAF even works on vanilla SupCom). I just reinstalled SupCom and FA to replay the campaigns, and like you said, having to keep re-entering the console command gets annoying (thanks for the command BTW, would've uninstalled the games if it were impossible to fix).

Yeah, the mod has gone from a necessity to a QoL thing :).

The same issue exists on a Surface Pro 7 with the Intel built in graphics. The fix is the same to use the d3d_WindowsCursor console command.

@GreenKn1ght You saved my life ♥

I've tried much of the solutions above, only fix I've found is either dropping mouse polling rate to ~125hz or installing an older driver (I'm using 457.51)
I do want to update this to say that the newest driver (461.72, released today) still causes this issue. Just finished testing it out in a private match, without any additional people. In fact, I think it's actually gotten worse with the latest update. Gonna be reinstalling the old drivers again.

I wonder if nvidia is even aware of this problem... I mean its 3 months now...