Fails to load textures: bad path on Linux

0

The map clearly was missing major textures in game, so I looked in the log and found lots of warnings like this:

warning: Unable to load texture: z:\home\%USER%\.faforever\user\my games\gas powered games\supreme commander forged alliance\maps\azalea_gardens.v0004\env\decals\wm_azalea_gardens_nm.dds

I have this path on my system:

'.faforever/user/My Games/Gas Powered Games/Supreme Commander Forged Alliance/maps/azalea_gardens.v0004/env/decals/WM_Azalea_Gardens_nm.dds'

Notice anything? Yes, I have a case-sensitive file system, and for some reason all paths were converted to lower case. No surprise then that it couldn't find the texture.

Is this a map bug or a game bug? Most maps look fine.

0

It is how FA works unfortunately 😞

My github repo with UI Mods

0

If your file system is case sensitive then you are going to have some struggles since the game was built for windows and assumes it is fine with case insensitivity. There are lots of places where case is just ignored.

0

Thanks for the advice. I switched to a case-insensitive file system:

  1. Create a sparse file: dd if=/dev/zero of=faforever.ext4 bs=1 count=0 seek=16G
  2. Format as ext4 with case-folding: mkfs -t ext4 -O casefold faforever.ext4
  3. Mount: mount faforever.ext4 faforever
  4. Move all game data there and create sym-links

... but the Azalea Gardens map still doesn't work right:

warning: Unable to load texture: z:\home\%USER%\.local\faforever\maps\azalea_gardens.v0004\env\decals\wm_azalea_gardens_sm.dds

If I replace back-slashes with forward-slashes that path works. I guess I should give up.

0

maybe the texture is corrupted, not completely downloaded? What if you delete and re-download the map?

A work of art is never finished, merely abandoned

1

Success! Thanks Jip.