Game crashes somewhere after 15 minutes

0

I dont know what is causing it. Here is the log game_18341783.log

Thank you so much if you are able to help. I would really like to play again after 11 years.

1

What have you tried to solve the error?

Reinstall everything and try without having the files in the cloud.

0

@magge Thanks for your reply. First i verified game cache intergity in steam and it still keeps crashing. Then tried reinstalling Forged alliance and the crashes still keep happening I can still try and install FaF.

1

Just to reiterate, having files in the cloud can and will lead to issues, try to avoid using onedrive for FAF unless you know what you are doing.

It would also be helpful if you can specify what you mean by "did not work". Do you mean you were unable to do that or that the game still crashed after about 15 minutes in vanilla (steam) supcom?

2

@deletethis thanks for the reply! I adjusted my previous comment to be more clear. I just looked again at the logs and i that some files are indeed in one drive. I have a new pc and i has no idea the user/appdata files are now in one drive. Ill try to adjust this when i get back home.

0

I managed to get the crash report from forged alliance by dragging it with alt tab to a new desktop:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at address 0x0289d220
attempted to read memory at 0xe0000000

Program : C:\ProgramData\FAForever\bin\ForgedAlliance.exe
Cmd line arguments : /init init.lua /nobugreport /log C:\Users\Qja_r\AppData\Roaming\Forged Alliance Forever\logs\game_18357399.log /gpgnet 127.0.0.1:5952 /mean 1500.0 /deviation 500.0 /savereplay gpgnet://127.0.0.1:53129/18357399/Molok.SCFAreplay /country NL /numgames 0 /numgames 0

Callstack:
Unknown symbol (address 0x0289d220)

Last 100 lines of log...

debug: Detected an AI with skirmish systems: ARMY_2, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_3, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_4, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_5, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_6, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_7, enabling AI functionality
info: * OnCreateAI: AIPersonality: (medium)
debug: Detected an AI with skirmish systems: ARMY_8, enabling AI functionality
warning: NUM PROPS = 5182
debug: Active mods in sim: \000
info: Hooked /lua/ui/game/gamemain.lua with /mods/noshake/hook/lua/ui/game/gamemain.lua
info: cam_ShakeMult 0
warning: SND: Error playing cue 1 on bank 40 [ursstream]
XACT: Invalid arg
info: d3d_WindowsCursor on
info: Cam_Free off
debug: [uiutil.lua, function UIFile()] - Unable to find file:/textures/ui/uef/icons/units/ura0001o_icon.dds
debug: [uiutil.lua, function UIFile()] - Unable to find file:/textures/ui/uef/icons/units/ura0002o_icon.dds
debug: [uiutil.lua, function UIFile()] - Unable to find file:/textures/ui/uef/icons/units/ura0003o_icon.dds
debug: [uiutil.lua, function UIFile()] - Unable to find file:/textures/ui/uef/icons/units/ura0004_icon.dds
debug: [uiutil.lua, function UIFile()] - Unable to find file:/textures/ui/uef/icons/units/zxa0001_icon.dds
info: creating medium fidelity terrain
info: creating low fidelity water
info: range_RenderHighlighted true
info: range_RenderSelected true
info: range_RenderBuild true
info: cam_DefaultMiniLOD 1.8
info: creating medium fidelity terrain
info: creating low fidelity water
info: cam_DefaultMiniLOD 0
info: res_AfterPrefetchDelay 100
info: res_PrefetcherActivityDelay 1
info: ui_RenderCustomNames 0
info: UI_ForceLifbarsOnEnemy 0
info: SC_FrameTimeClamp 6.0606060028076
info: /savereplay
info: Exe GitSHA: e35f167
debug: Current gametime: 00:00:00
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
warning: SND: Error playing cue 1 on bank 5 [music]
XACT: Invalid arg
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
info: Exe GitSHA: e35f167
info: *AI DEBUG: ARMY \0002\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0003\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0004\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0005\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0006\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0007\000: Initiating Archetype using ChallengeMain
info: *AI DEBUG: ARMY \0008\000: Initiating Archetype using ChallengeMain
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
info: Minimized false
info: Minimized true
debug: Current gametime: 00:00:30
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
warning: GetResource: Invalid name ""
info: Can't find texture "" -- trying fallback.
info: Minimized false
debug: Current gametime: 00:01:00
info: AIGetMarkerLocationsEx 20 markers for Land Path Node
info: AIGetMarkerLocationsEx 16 markers for Water Path Node
info: AIGetMarkerLocationsEx 26 markers for Air Path Node
info: AIGetMarkerLocationsEx 32 markers for Amphibious Path Node
debug: Current gametime: 00:01:30
debug: Current gametime: 00:02:00
debug: Current gametime: 00:02:30
debug: Current gametime: 00:03:00
debug: Current gametime: 00:03:30
debug: Current gametime: 00:04:00
debug: Current gametime: 00:04:30
debug: Current gametime: 00:05:00
debug: Current gametime: 00:05:30
debug: Current gametime: 00:06:00
warning: SND: Error playing cue 1 on bank 5 [music]
XACT: Invalid arg
debug: Current gametime: 00:06:30
debug: Current gametime: 00:07:00
info: CWldSession::DoBeat() unknown entity id (0x2ff001df) supplied in a pose update.
debug: Current gametime: 00:07:30
debug: Current gametime: 00:08:00
debug: Current gametime: 00:08:30
debug: Current gametime: 00:09:00
debug: Current gametime: 00:09:30
debug: Current gametime: 00:10:00
debug: Current gametime: 00:10:30

1

You have sound errors: warning: SND: Error playing cue 1 on bank 40 [ursstream] - make sure to play the game using Stereo sound settings. I'm not familiar with where the guide for this is, but @magge knows

A work of art is never finished, merely abandoned

1

Good thing: You fixed the old script error
Bad thing: Now there is a sound error, but relatively easy to pinpoint:

https://forum.faforever.com/topic/4084/solutions-for-snd-error-xact-invalid-arg-xact3dapply-failed

1

I managed to fix it. I had to go in the registry and there adjust where my user>documents is located. I changed it to be on my regular C : drive. I tested it and i played a game without crashing. Thanks everyone!

0

@magge Thanks! I thought that was the original problem but i turned the music off anyway.