faf not starting - cartographic.fx reason: unknown error

Hi guys, I installed FAF on new PC with steam version of Supreme FA. I tried to start FAF but I received error all the time. I tried to find solution with uncle google, I found some advices (path to right folder, delete programdata etc..), I think I tried everything but nothing helped. I am able to start Supreme FA from steam without any issue, but via FAF nope.
AMD 5600G, RX 6700 XT (last version of drivers), Win 10
Pls help

Have you ever started a vanilla game?

“Be a yardstick of quality. Some people aren’t used to an environment where excellence is expected.”
— Steve Jobs.
My UI Mods

Yes I have

Just to be sure; You have pointed the game location in FAF correctly, right?


Yes I have. I tried delete programdata, start as admin, rename supremecommander.exe to forgedalliance.exe etc..

I player FAF on another PC but on this new machine I am not able to solve it

The file cartographic.fx is the first shader to be loaded, the error being unknown means:

  • there is a driver issue, but the steam version works so it is likely not that
  • the .nx2 that contains the shader (effects.nx2) is corrupted somehow
  • your anti virus is blocking access to the .nx2 (effects.nx2) somehow

I suspect it is one of the last two

A work of art is never finished, merely abandoned

  1. I tried to install different amd drivers, even one year old
  2. FAF reinstalled
  3. I dont have any standalone AV or FW, just WIN builded, I turned them off

nothing helped
I just not tried reinstall windows 😕