Random graphics engine crash mid-game. "AeonBuildNoAnimation"

Hi everyone,

I am experiencing a strange crash mid game. It does not always occur, perhaps about 50% of games. In the logs of games that have crashed, I noticed that a warning is thrown:

warning: attempt to retrieve annotation from unknown technique AeonBuildNoAnimation
warning: c:\work\rts\main\code\src\libs\gpggal\EffectD3D9.cpp(89) invalid effect technique requested: AeonBuildNoAnimation

The graphics engine completly shuts down, flashing and glitching. It is completly frozen. If I alt+tab and return, it is black. The game still runs in the background with sound and it does not cause a disconnect, but it is obviously completely unplayable.

I have latest nvidia drivers, and have tried restarting, validating files on steam and disabling nvidia's overlays and extra-features. No luck.

Would anyone be able to shed some light on this issue for me please? Sample of logs attached.


After browsing the discord for a while I managed to locate some people experiencing the same crash. They recommend playing one game in "FAF develop" mode (Selected when hosting a new lobby). Starting a game, then leaving, and resetting to normal FAF. Apparently it should fix it. I'll give it a go and report back.

The solution is correct. You can test it by spawning in a quantum gateway and try to build a SACU.

The question is however, how did your shaders end up using and older version? Could you tell me whether you played other game types (nomads, phantoms) or steam FA?

A work of art is never finished, merely abandoned

Hey Jip, thanks for your hardwork. A few of the times I crashed I wasn't Aeon, and every time I crashed I hadn't even built a quantum gateway, although maybe my opponents were starting too. I had only played default FAF, no versions, not Phantom or Nomads and definitely not Steam FA.

Strange glitch but hopefully no more issues!

Did you by any chance watch an old replay? 🙂

A work of art is never finished, merely abandoned

Yes I did! Is that the cause?

It could very well be - could you confirm it for me? Anything from the year 2020 or before would cause this issue.

A work of art is never finished, merely abandoned

I got this crash in current coop as well, 16562051, last version of Blocade mission from the coop discord, second part of the missions
I've tried to delete shader cache as well, didn't help.