Replays and strategic icons


Enjoying FAF but I have two three questions:

  1. How far back is it possible to watch replays? I am finding that trying to view replays more than a couple of months old I seem to either get an FAF Client error (See below for detail) or else the replay de-syncs almost as soon as it starts.

  2. The "bigger strategic icons" in game option doesn't work, they look the same whether this option is "off, on, or on with tech indicator" Is there another way to make these icons bigger?

  3. Is there somewhere I can download all the commonly played maps in one go, rather than individually through the client?


FAF Client error message:
############################### Cannot run program "C:\ProgramData\FAForever\bin\ForgedAlliance.exe" (in directory "C:\ProgramData\FAForever\bin"): CreateProcess error=193, %1 is not a valid Win32 application
at java.base/java.lang.ProcessBuilder.start(
at java.base/java.lang.ProcessBuilder.start(
at com.faforever.client.fa.ForgedAllianceService.launch(
at com.faforever.client.fa.ForgedAllianceService.startReplay(
at java.base/java.util.concurrent.CompletableFuture$UniRun.tryFire(
at java.base/java.util.concurrent.CompletableFuture.postComplete(
at java.base/java.util.concurrent.CompletableFuture.postFire(
at java.base/java.util.concurrent.CompletableFuture$UniHandle.tryFire(
at java.base/java.util.concurrent.CompletableFuture$Completion.exec(
at java.base/java.util.concurrent.ForkJoinTask.doExec(
at java.base/java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(
at java.base/java.util.concurrent.ForkJoinPool.scan(
at java.base/java.util.concurrent.ForkJoinPool.runWorker(
at java.base/
Caused by: CreateProcess error=193, %1 is not a valid Win32 application
at java.base/java.lang.ProcessImpl.create(Native Method)
at java.base/java.lang.ProcessImpl.<init>(
at java.base/java.lang.ProcessImpl.start(
at java.base/java.lang.ProcessBuilder.start(
... 14 more

At one point, not sure when, there were issues with replay server. A lot of replays were unfortunately desynced. However your own local copy would still usually be okay.

The bigger strategic option only affects the icons in the build menu. For unit icons you can download from vault, Brewlan, eternals, or redux icon mods. There are posts for these in forum with more info and pics.

There isn't any official map repository other than vault, unless someone has uploaded their own map folder somewhere.

@Fo0L That error means that your computer didn't finish downloading the old versions of the game to play the replays properly make sure you don't cancel the download or have anti virus that interferes

@macdeffy Thanks for the info. I will try the mods you mention

@Sheikah That makes sense, I think I accidentally interrupted the downloads a couple of times. But how do I force FAF to re-download the files again? I dont see anyway to do so within the client.

You just have to play the replays again they auto download before the game starts

@sheikah Ah yes sorry, my bad. I'm no longer getting that error.

But I still have yet to get a replay working that is older than august last year, they now all desync/crash in the same way (pic attached in case thats helpful)

Am I doing something wrong or are these replays just broken?

Replay for below pic is:

FAF desync.png

What is that yellow box? 🙂

A work of art is never finished, merely abandoned

I have no idea. It shows up along with the "desync" box and dialog within 5 seconds of replay start.

Whatever's going on makes it impossible to click on anything. To exit the game from here its necessary to press alt-f4 and then press enter.

In order to watch old replays, it's best to turn off all of your UI mods in the client. Otherwise, your active UI mods, which are made to be compatible with the current version of the game, can cause inconsistencies.

@arma473 Thanks for the suggestion. All mods are off, still desyncing

@Sheikah Uh oh. I AM getting the same error again. (see pic) Doesn't matter how many times I re-try the replay. Have tried restarting client, logging out and in again, same problem. I seem to have a knack for breaking things!

FAF replay error.png