Yellow build ring when setting up string of instructions?

I got a new HD and have had to reinstall FAF and all my mods etc. I have everything setup the way it was other than one thing - I no longer have a yellow ring that shows building range. It's vital when holding down shift to set up a chain of commands. Is this something from a mod that i've forgotten? Can't find an in game setting for it either?

It's not the Build Preview Condition in the Strategic Overlay Menu, I have that set to ON but no joy.


Its mod Additional camera stuff

β€œBe a yardstick of quality. Some people aren’t used to an environment where excellence is expected.”
β€” Steve Jobs.
My UI Mods

Hmm, i definitely have that installed - where do i turn on the build ring??

The button to access options for that mod is on the mini-map. I think it's a picture of a wrench or something. There aren't that many buttons on the mini-map so it should be easy to figure out.

If your mini-map is not visible, I think you would have to enable the mini-map in order to see the button in question.

YES ! that's me sorted, thanks arma473 and BR4Hz0t πŸ™‚

Ok, this is gone again since the latest mega patch. How do I get my yellow build ring back? I was using the mod "additional camera stuff" but bizarrely I cannot see it listed anymore in my mods list during game setup. I have deleted and reinstalled the mod but it's just not listing. I also tried the mod called "build range preview" that's quite new but no joy either.
Help! Am I the only one with this issue?

UPDATE - it's mysteriously reappeared thankfully, something I did must have fixed it πŸ™‚

@laconic you didn't read the latest patch notes, here's the thread with the relevant information. Further in that thread I had your same question and got my answer, which you already found anyway with that mod. Eventually, we'll get back the other range rings too, I hope...