RNGAI mod Desyncs

A friend and I are having trouble with the RNGAI mod where at anywhere around the 5-15 minute mark in any game we start getting tons of desync messages. We've pretty much narrowed it down to that mod being the issue as when disabling it, we can get through a whole game (~90 minutes) without any desyncs. We've made sure that we have the same versions of all the mods and even deleted the mods folders and reinstalled them through FAF. We've tried multiple potential solutions, but have pretty much exhausted all options at this point.
Here is my game log file: game_15913175.log
And my friend's log file: game_15913175.log

With the people I've helped with this problem. The issue has always come down to an update issue where one person's machine has updated from a previous version of rngai to a newer one but the folder contents don't match.

So far in those cases the users have been able to fix the problem by manually deleting the mod folders from the machine and downloading the mod again(once they had to do the same with Uveso).

We've manually deleted all our mods folders and re-downloaded them multiple times already to no avail. I just don't know what else to try.

Does it happen on all maps? Curious if it happens to you on maps with no water.

On the next version I'll add a file integrity check so it can produce an error if the files for each player dont match.

@brickman does either of you use the backup vault location? The mod can be at the original location.

A work of art is never finished, merely abandoned

@relentless We haven't tried any maps with no water recently. We'll try that and I'll let you know if we get desyncs or not.

We successfully completed a map with no water without desyncs. So it must have something to do with naval units.

@jip What's the backup vault location?

This post is deleted!