FA Crashes when loading some save games

Hi All,

I was trying to avoid posting a request for help here as i generally like to solve issues myself but i cannot find anything similar to my issue here on the forum.

I'm playing a lot of Skirmish against the AI and i save my game periodically. It seems that if i try and load my later saves it results in a crash and return to desktop with the error reporter to GPG.

It seems to impact saves once a T4 unit is being built/has been built - that's the only two things i can seem to join up, generally i can return to a much earlier save and play the game through to the end but this leads to hours of lost time.

Have tried deleting game prefs and running the exe in compatibility mode but no luck.

Would really appreciate if anyone might be able to shed some light on the situation?

Logs attached - TIA!

Logs.zipcrash screen.png

Are we talking about FAF or the steam FA version?

A work of art is never finished, merely abandoned

I've installed FAF and play online sometimes but this is playing skirmish via the FA launcher: C:\ProgramData\FAForever\bin\ForgedAlliance.exe

This is the only other similar problem i've found...


I've opened the .dmp file from the logs and also have the same problem....What does it all meannnnn?


Key  : Analysis.CPU.mSec
Value: 4796

Key  : Analysis.DebugAnalysisManager
Value: Create

Key  : Analysis.Elapsed.mSec
Value: 94904

Key  : Analysis.Init.CPU.mSec
Value: 437

Key  : Analysis.Init.Elapsed.mSec
Value: 101054

Key  : Analysis.Memory.CommitPeak.Mb
Value: 121

Key  : Timeline.Process.Start.DeltaSec
Value: 44

Key  : WER.Process.Version

CONTEXT: (.ecxr)
eax=00000eab ebx=00000001 ecx=4c2830ef edx=00000000 esi=00000001 edi=00000000
eip=00a82172 esp=4c283000 ebp=4c28300c iopl=0 nv up ei ng nz na po nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010282
00a82172 ff7510 push dword ptr [ebp+10h] ss:002b:4c28301c=126dd155
Resetting default scope

ExceptionAddress: 00a82172 (ForgedAlliance+0x00682172)
ExceptionCode: c00000fd (Stack overflow)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 00000001
Parameter[1]: 4c282ffc

PROCESS_NAME: ForgedAlliance.exe

ERROR_CODE: (NTSTATUS) 0xc00000fd - A new guard page for the stack cannot be created.




WARNING: Stack unwind information not available. Following frames may be wrong.
4c28300c 00a88a52 4c2830ef ffffffff 126dd155 ForgedAlliance+0x682172
4c283040 00a88c10 4c2830ef ffffffff 00000001 ForgedAlliance+0x688a52
4c283088 00a88c48 4c2830ef ffffffff 00000001 ForgedAlliance+0x688c10
4c2830a0 00905188 4c2830ef 00000001 00000001 ForgedAlliance+0x688c48
4c2830e0 00905692 4c2830ef 00000000 00000000 ForgedAlliance+0x505188
00000000 00000000 00000000 00000000 00000000 ForgedAlliance+0x505692

SYMBOL_NAME: ForgedAlliance+682172

MODULE_NAME: ForgedAlliance

IMAGE_NAME: ForgedAlliance.exe

STACK_COMMAND: ~45s ; .ecxr ; kb

FAILURE_BUCKET_ID: STACK_OVERFLOW_c00000fd_ForgedAlliance.exe!Unknown


OSNAME: Windows 8


FAILURE_ID_HASH: {531ac4bf-c994-a2cb-a384-f91e59c83256}

Followup: MachineOwner

Are you trying to load saved game files that were created before you downloaded the most recent gameplay patch?

To confirm i've also tried the following:

Uninstalled Sonic Studio and tried running the exe without sound as detailed here (https://forums.faforever.com/viewtopic.php?f=3&t=15689)

Set the graphics to lowest possible.

Run exe as administrator and tried all compatibility options.

Mods deactivated:
Retirement V1.0
Resource Rich V1.0
Nothing But Time V1.0
Chess V1.0
Total Annihilation Music V4.0

And this was a saved game load from last night

V1.6.0 FAF

Savegame file is 222.5mb in size (cant share here due to size and not sure if you can take it and load it to test?)

Still no luck.

v1.6.0 is the client version. I'm talking about the gameplay patch. That's a separate thing. The FAF patch history isn't up to date on the wiki and I don't know where to find it on the web site. But there have been multiple patches in the last few weeks.

Here is a thread in the forums about some of the recent gameplay patches:

The most recent patch is from October 4. But that's not necessarily the day that you downloaded the patch. You would only download the gameplay patch when you log in to FAF through the FAF client, and try to join or host a game, if you don't already have the most recent patch.

I'm running game patch 3724 and this issue has predated this patch.

Appreciate your responses 🙂

One thing that isn't clear, does it crash the instant you try to load the save game? Like it crashes before you have a chance to give any orders? Or is the problem that the save crashes soon after you load, for example if you get to play for 60 seconds before it crashes.

Updated the original post with a screenshot. The "In Transit" screen does it's thing but it looks like it crashes just before the game renders and then exits to windows.

So to confirm, i do not actually reach "In Game"

and it only impacts some "mid to late game" saved games (usually once a T4 unit eg CZAR, Mavor, Novax) is being built/has been built on the map.

I have honestly no idea 😞

A work of art is never finished, merely abandoned

I don't seem to have this issue when playing via the steam launcher.

I've also re-installed the game and FAF Client but have the same issue when launching via the patched exe.

Do the logs not give any indication as to what might be happening?


I have also been experiencing this saved and restore issue. I've been experiencing for over a month, and I keep very updated with my patches. It doesn't matter whether I start it from the executable in the file directory or from Steam, it seems to do with the size of the save game as if I only play for a minute and save, it will sometimes load, but any decent size game that I saved, it just won't load. It gets pretty far into the loading screen as it's been for quite a while and then I noticed it kind of stops the loading screen animation, and then the animation starts again again and then it crashes.

Can you share such a save game?

A work of art is never finished, merely abandoned

Sorry for the delay, Still loosing lots of time with this scenario.

Saved Game:
YSTD - Saved Game Example

TIA @Jip

This sounds a bit silly, but how do you load that in?

A work of art is never finished, merely abandoned

What do you mean by that @Jip ?

If you mean how do i load the saved game...

I run the patched .exe via

Click "Skirmish" and click "Load game" then select the saved game file.

The Skirmish is started the same way, using the patched exe.

Hey @Jip , I know it's been a while but this issue is still happening? I was wondering if you ever found out what might be causing this issue?

Please see the following link for two save games - One that loads (4) and one that doesn't (5)

Would really appreciate if you could shed a little light on the situation...Do they both load for you?

Thanks David

My apologies for not getting back to you. I've not been able to shed light on the situation. I think, somewhere down the line, the loading / saving of games was never really tested when patching the game. And I do not recall testing it either.

I've stored your save files on disk and I'll see if I can find something. If it turns out to be trivial to fix then I can fix it for the next developers patch, but if it isn't trivial then I'm afraid it will be postponed.

A work of art is never finished, merely abandoned

No need to apologise @Jip , I'm sure you've got plenty more pressing things on your plate. The only difference i can see is similar to what @camber mentioned before - Any saved game over the 200mb file size seems to cause the crash when loading. Fingers crossed it's something simple - Normal Forged Alliance Skirmish is nowhere near as fun playing FAF Skirmish 🙂