FAF client: Can't download some of the maps


I am unable to download some of the maps from the "Maps"-tab. Some of the maps download without any problem, but many throws this same error.

'java.util.concurrent.CompletionException: java.nio.file.AccessDeniedException: path\My Games\Gas Powered Games\Supreme Commander Forged Alliance\maps\Stella Maris v3.v0001\stella maris v3.v0001.small.png'


stella maris v3.0001 isn't a valid map it doesn't exist

Vault Admin / Creative Team / Map Guru

@madmax Hm, interesting. This is directly from the "Maps"-tab


i just tried downloading that map it worked for me what ever the issue is it's on your end

Vault Admin / Creative Team / Map Guru

It may be that another process is blocking access to those files. Did you check your anti virus?

A work of art is never finished, merely abandoned

Yup, that was my expectation that it's on my end. Antivirus shouldn't be the issue, as I can download some of the maps?

Just disable the antivirus and try it.
Btw, you only need Windows Defender nowadays anyway, extra antivirus is not needed.

The error you are getting is "typically due to a file permission or other access check. " so it could also be related to folder permissions.

And you can try the "Vault Fallback Location" setting in the client.

Right, that Vault fallback location fixed the issue! Thanks! 🙂