Unable to create Direct3D. Please ensure system has current video drivers.


java.lang.RuntimeException: Forged Alliance Crashed with exit code -1073740771. See game_14847229.log for more information
at com.faforever.client.game.GameService.lambda$spawnTerminationListener$43(GameService.java:696)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
at java.base/java.lang.Thread.run(Thread.java:832)


This happens when I try to host a custom game. I haven't installed any mods. This is the first time I've tried FAF for years. It was suggested in another thread to try installing DirectX 9.0c. That didn't make any difference.

Run supreme commander through steam first of all,it will instal the necessary directories

queuing with a newbie to show him the beauty of tmm and meeting tagada be like:

I ran both the original and Forged Alliance already. Ran them both again. Still the same.

did you do it trough steam though?
i recall having the exact same problem and it gor fixed after i run it on steam

queuing with a newbie to show him the beauty of tmm and meeting tagada be like:

Yeah, I did. I think I know what the issue was. The original Forged Alliance doesn't close properly. It's a problem that I have with some other games on Steam for some reason. So, the process was still running in the background. After ending it, creating a game in FAF seems to work fine now. Now, I have to figure out why some games in my Steam library don't close properly, but that's outside of the scope of this forum...

Did anything help? this error usually indicates problems with directX9
You can try to install it, or if you did can maybe try uninstall and try running vya steam again maybe.
Tho make sure you install and uninstall things with windows install\uninstall manager or uninstaller file and not by manually deleting files (mentioning that just in case).

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

@zlo I think you managed to miss the last reply from OP.

since yesterday i get the same message as the OP, and have no idea why.
things I tried since that:
-all kind of selections when you right click the supremecommander.exe (combability mode, start in 640x480,... everything possible)
-deleting and reinstalling supcom
-installing directX from the supcom folder
-of course several restarts
-starting the game from steam directly (same message), the last several tries after restarting the PC were always just directly from steam

anyone has an idea whats causing this? before this weekend i was able to play without problems, since yesterday no chance

random guess #1:

Whatever graphic card you have, reinstall its driver & software, restart pc, try again

nvidia -> https://www.nvidia.com/download/index.aspx
amd -> https://www.amd.com/en/support

ok, I tried. I reinstalled the newest driver (which was already installed, dated 15.06.2022)
-> did not work
I thought, 15.06 is quite new, so maybe thats the reason
so i installed an older version (GeForce Game Ready-Treiber WHQL 472.12 September 20, 2021), and

so thank you for guiding me to the right path, and for information if anyone else has the same problem with the newest nvidia driver

-having this same error message problem in 2023, with a new machine having reimported my Steam library, now an i9-12900 with 3080 mobile. Tried the usual in-game resolution fixes, tried wiping and redownloading SupCOM:FA, have now tried FOUR revisions of GF drivers from 517.66 (Dell Oct22 bundle) to the latest Nvidia 528.48 (Feb23). Same error every time. I've also tried tweaking the driver settings for SupCom, disabling various 3D functionality. No difference at all.

I suspect something global rather than specific to SupCom, as TF2 also crashes out on startup without any error message. I haven't investigated it directly yet, it was just to compare to SupCom.

maybe stupid question but do you have direct x itself installed