Need help with fixing some units not getting destroyed and become wrecks from some old mods.

0

I've noticed that on some old mods some units when destroyed not becoming wrecks and stayed permanently as damaged model and can't be reclaimable.
Before all these units was working fine in FA and now in FAF they have this issue.
Mods affected: 4th Dimension & Antares unit pack and possibly other mods.
Only some units affected and other units are working fine.
Please see example of affected units attached:
[https://drive.google.com/file/d/1-2LC1wsh2gUT_MF_WV_8dxqTwd13eqKQ/view?usp=sharing](link url)
I've tried to ammend unit buleprint and unit script, but not able to fix it.
Please help.

0

i think that only the author has the rights to change/develop his mod,it is possible to make your own changes but then again,you need the author to grant you the rights,deal with that first and then you can ask for help in the Creative discord.
https://discord.gg/2qjNYBz6

0

@rezy-noob I'm not going to develop this mods. Just want to know how to fix this issue as playing bugy mods is not good. I'm not expecting to hold any rights for this mods. Also these mods are no longer in development for a long time and i have no idea on how to contact autors as forum pages of this mods are long forgoten and even forums are no longer active.
My quescion is technical, how to fix these units as example.
Regards.

0

I only checked unit URS_EnCl and it has 97 (ninety seven) errors inside the Blueprint.
Way to much to explain how to fix this unit.

This is a old patch i have done in 2016. Maybe this will work with your version.
URS_EnCl_unit.txt

0

@Uveso Thanks. So issue with units not getting destroyed and leaving reclamable wreck is in unit.bp file?

0

No, if a unit is causing a LUA error, then the game can't destroy and remove the unit correctly.
Watch the game.log. You will surely see some WARNINGS:(errors) then.

0

@Uveso I've tried to use your URS_EnCl_unit.txt but same issue presist. Just to let you know.

0

Sadly there is nothing more i can do.
The posted units have links and try to include 4th dimension files.
So i can't debug them.
But as example the unit URS_EnCl is working if placed alone in a mod.

Did you read the readme from Antares Unitpack:
Note: Errors encountered while playing with 4th Dimension 2.12 and 4DC 0.83, so better to keep both of them deactivated (if available).

0

Thanks for looking at this. I was hoping that there is easy fix. Booth mods having this issue even if played separately with no other mods activated. 4th Dimension mod having issue with only these 2 units attached in first post. Antares unit pack having this issue with multiple units and URS_EnCl was one of afected units. I think something was changed in FAF that these units stoped working properly as 4th dimension units was working fine in vanila FA.