Cannot select "environment", login fails

I played this morning. It worked well.
Then I got disconnected after putting the computer in hibernation. It didn't peep, just prevented from starting a game and displayed no public game.
I closed and restarted the client (and then the PC) to login back. The "environment" field is empty, with no choice available.
Any attempt to connect yields a "lost connection to server during login" message.
Any help would be welcome about how to fix it and how to avoid in the future.

If that environment field is empty it means the client couldn't connect to the server to get the details about where to connect to. Check your av isn't preventing the client from communicating.

No AV. I changed nothing since when it worked.

Post logs maybe


It looks like it solved itself. I've no idea what happened. I would like to know, if possible, so that I can avoid it in the future.

Connectivity problems like this are beyond our control. The FAF client expects a working network connection, and if it doesn't have one it will malfunction.

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
– Benno Rice

I had this intermittently last night, assumed it was external factors.