Linux Support

1

Hi everyone. I was having issues with fonts not rendering in the launcher on archlinux. The issue was fixed by installing Microsoft's fonts using the package "tts-ms-fonts" from the AUR.

Just posting it here in case anyone else has the same issue in the future

1

I did a lot of playing around with linux faf today and i got 2 notable bits of info to share will everyone.

  1. If you (like me) have extreme stuttering during the launch animation and the score screen, i have found a way to remove it (at the cost of some looks). To remove it u need to take this https://imgur.com/a/MoKYCZJ command and add /nomovie to the end of the command after the %s. This removes all videos/movies from the game.

  2. Jip will be putting out a video on how to setup a development environment for FA. I went through and created a script that would allow us linux users to contribute as well. It will be located here as soon as my pr is accepted https://github.com/Spikey84/fa/tree/deploy/fafdevelop/setup/bin

0

Hey I installed FAF from the Aur and used my run file from proton, linked it and did everything right, but I cant enter a custom match, ICE Adapter doesnt load properly

0

@daz1st hey, would you mind posting your STEAM and FAF command line options? This may help try debugging ur problem further.

0

Sure, just a sec,

0

they are
PROTON_NO_ESYNC=1 PROTON_NO_FSYNC=1 PROTON_DUMP_DEBUG_COMMANDS=1 %command%

0

What about the FAF command line?
Do you have any useful debug logs? May start faf-client from CMD and watch the output or use the debug-log option in settings.

0

I have a similar problem as daz1st, I'm running EndeavourOS as distro.

I have followed the stops throughly on https://wiki.faforever.com/en/Linux-Install

I'm able to run SupCom from steam with no problems, just running SupCom with FAForever that's not working

FAF: ~/.faforever/run "%s" /nomovie
STEAM: WINEDLLOVERRIDES="d3d9=n" PROTON_NO_ESYNC=1 PROTON_DUMP_DEBUG_COMMANDS=1 %command%

From FAForver terminal: https://pastebin.com/TSh3xMRa

Nevermind I found out the problem.

Thought that arch-based put the client in ~/.faforever/
Solution:
cp /tmp/proton_$USER/run /usr/share/java/downlords-faf-client

and then in Command Line Format for Executable in FAF-Client
/usr/share/java/downlords-faf-client/run "%s" /nomovie

0

Yes, don't use realtive paths in the Startup commands, this got me twice, too 💨

Maybe someone with editorial permissions adds this information to the Wiki?

0

the best place to get faster support is in the dedicated #linux-support channel on the discord. their are people there who are running faf on linux that may be able to help quicker than on the forum

"The needs of the many outweigh the needs of the few" - Spock