I cannot see any units upon loading a game

I load a new game and no units are visible, the only MOD selected is the Forged Alliance Forever default mod.

I have tried a clean install of both the steam Forged alliance and FA Forever client, but have the same issue.

When I click on the first item to build, the game will hang. Log File attached.


This is my first time trying to get FAForever setup, does anyone have any idea as to what I am doing wrong?

start fa.png

no units visible fa.jpg

what mod are you running ? as it showws you have 1 selected

are you not running the FAF client and Donwloaded the FAF Development from Github and put that in the mods folder ? if so this is not what you need to do

"The needs of the many outweigh the needs of the few" - Spock

Can you show what "Defualt mod" is seleceted ass faf dose not have a defult mod that would show up

"The needs of the many outweigh the needs of the few" - Spock

1 - Why does the log show "FAF_Develop"? That doesn't show up in my logs.

2 - Have you tried joining other people's games? Are you able to do that? I would be happy to host a game just to test if you're able to play it. You can always ask in Aeolus if someone will host a game for you to join so you can test if it works.

3 - have you tried watching a replay from the replay vaults? Does that work?

This is the mod that I thought was the one that came as standard:


However looking at the other active games, it does not list that mod as one that they have selected.

Is this Forged Alliance Forever Mod not the base mod that this FAForever community uses for rebalance?

If I create a game with no mods then the game runs ok, is this Forged Alliance Forever mod not the official standard one that should be used?

I am not sure why it was available by default.

I'm not sure why you have that "Forged Alliance forever" mod in your mods folder, but you should delete it.

If you want to run Supreme commander Forged alliance with none of the FAF improvements or balance you need to run it from steam.

To launch a standard game of FAF all you need is game type FAF and no mods. That will give you a game with the base FAF "mod". It's not really a mod of SC FA, more like a stand alone expansion of the game.

^ You need to delete that mod as you dont needed it that mod you have got thier contains stuff the game has know idead what it in it hens the reason not working correcly all you need is to have the FAF selected in game type and no mods seleceted

"The needs of the many outweigh the needs of the few" - Spock

@CloseKill Thanks for posting the screenshot, that makes it much easier for us to help you.

We don't know what that mod IS, but we're sure it's causing you trouble. You should definitely turn it off. You can turn it off just by clicking on it, so it's not highlighted.

You might want to delete it entirely. If you don't know what it is, then it's probably not anything that you will ever need.

Ah, thank you all for the help, it all appears to be running ok now. I incorrectly assumed that mod was essential and running without it was vanilla FA - I have no idea how it ended up in the mods list.

I will remove the mod so that I do not accidentally run with it!