Startup Crash

Hey guys, I've been struggling with these crashes for some time since I got my new PC I got a while ago. I've tried to fix it many times myself but unfortunately I've had no luck.

I've followed the steps in this thread but to no avail -

Unfortunately it still does not work. It does not even generate a client log for me either. I've uninstalled FAF client completely by deleting "FAF Client", "Forget Alliance Forever" in Appdata roaming, and even "Supreme Commander Forged Alliance" in "Gas Powered Games" in Appdata Local and installed a fresh copy of FAF with even my windows defender turned off, still no dice.

All I have is a large java error from startup. I ain't tech savvy to know what it means but maybe you guys can understand it? I have a theory because it's got something to do with my local username, but I don't know. I've even tried to reinstall Java just in case but that didn't seem to work either.

Here is the txt file for it: Startup Error.txt

The Windows username may causing issues:

C:/Users/Epic Gamer B)/

Can you try without any special char? A simple name, like "username", should work.

I'll try that.

@magge I've tried changing the account name in User Accounts in Control Panel but it doesn't change the local name.

For example: Local name.png

That hasn't changed. My new name should be "Ghost". However it hasn't changed this. How do I go about changing this?

You need to add a new Windows user account, login into that - Reinstall FAF/Supreme Commander as the new user, and then try to start Supreme Commander/FAF again.

Changing a local account name retroactively is not designed by windows. It is kinda possible, but can have a lot of side effects and should not be done by a non-savvy IT user.

I've created new account and moved my files there. Everything works swell and dandy now, I think. I haven't actually played it yet but I'm able to log in and actually see the launcher.

Thanks for your help mister, it has been greatly appreciated as I can now play the game.