Using two monitors of different resolution - is it possible?

0

I've got multiple monitors, my main is 1920x1080 (60hz) then I've got two 1280x1024 (75hz), one either side. I'd like to use one of the satellites for FA but when I try to set it in the options I don't get anything on the second monitor and the main monitor displays at a low resolution. I've tried it setting each to native refresh (i.e. 60 and 75) and also setting both to 60hz but no joy.

Any ideas if it's possible and if so what I need to do to make it work?

1

Yes, it's possible. I have two 4k monitors, one in portrait mode. For a long time I ran them at 3840x2160 and 1080x1920. Now I'm running them both at 4k (3840x2160 at 60fps and 2160x3840 at 30fps).

I'm not using "fullscreen" or "fake fullscreen."

When I previously tried to have 3D graphics on both monitors at 4k, it wasn't working smoothly. Now, my second monitor shows only the "cartographic map" so there are no 3D graphics on that monitor. That might be why everything is working out for me.

To be clear, I was always able to display the game on two monitors. But it ran choppy or something which is why I dropped the resolution.

Can I ask how your two satellite monitors are connected to your computer? E.g. is this an office machine where extra monitors are attached through USB cables? Are they plugged in with DVI cables directly to your graphics card? It sounds like the problem is that the game is not recognizing that a second monitor even exists.

One possible workaround is to use "fake fullscreen" with "ui-festival." You could set the resolution to 3200x1080, which would spread your game across 2 monitors. Then you use settings in "ui-festival" (which you can edit while the game is running, or by editing the game prefs file) to set the "SplitRatio" to exactly 60 (60%).

I think if you use fake fullscreen, then it might not matter whether the game recognizes your 2nd monitor. It would be sufficient that Windows 10 recognizes the second monitor. That's just a hunch I have.

Here is a link to the "Fake Fullscreen" instructions: https://forum.faforever.com/topic/123/guide-fake-fullscreen-and-optimisation

1

I have the same issue Wainan, have recently upgraded to a three monitor setup: 2560x1440 (144Hz), 3840x2160 (60Hz), and 2560x1600 (60Hz). Also have the same issue with the change of resolution. I do not think this issue can be overcome when there are three monitors connected and you try to run SupCom in dual monitor. This may be a legacy issue with the drivers. I get around this by physically unpluging one of my monitors from the video card, run Supcom in dual monitor, and then plug the cable back in when I am done. No need to restart as the monitor comes back and works as usual, windows remembers its position.

0

Thanks, I'll try both of those suggestions.

They are all VGA monitors attached to my GTX1060 with Display port to VGA adapters.

1

@The_Mak I unplugged one of the monitors and hey presto! Works a treat! Thank you very much.
DSC00101 (1920x1080).JPG

Log in to reply