Can't log in, Steam verification link is broken: 404


today I had to AGAIN, for probably the 10th time in the last years AGAIN had to prove that I own the game on Steam, which is pretty annoying.
It sent me to login via browser for some unknowable reason, it has worked fine the last times before, when this screen


blocked me from logging in.

Doing the verification properly (I know this well, as FAF makes me do this again and again over and over),

I get to a "404 page not found" error.

If you have successfully linked your account once with Steam/GOG, FAF should not ask to redo it again.

  1. What is your FAF account?
  2. Can you try a different browser without any extensions?
  3. Is your steam profile public?

You would assume that you don't have to do the verification again, but I have seen over the years that it does happen over and over again.

  1. Caipirinha_Pilot

  2. A 404 is not dependent on any browser, it will always show up, it means the website is not available.I don't understand why FAF is sending me in to "login with browser" in the first place, it worked fine a few weeks ago. I have noticed that if this is the case, there is usually something broken in the server that does not allow login.

  3. I know how to verify my steam profile for ownership, I have done it many many MANY times over the years.
    i.e. set the profile to public, do the verification and then switch it again to private.

Clicking the link "Link your FAF account to Steam" leads to this site:
404 page not found

The account Caipirinha_Pilot had no games in the last years. If you respond to my PM, I can look to which account you have attached your Steam profile and hopefully narrow down the issue.

There is some weirdness that I have seen a few years back, where there were two accounts that were identical? I never knew why these even existed, but it gave me grief back then. I have played quite a few games though in the last year, so the empty account is not it.
I sent you a PM.

As mentioned in the PM - It was just a mix-up between two old accounts.

This post is deleted!

Alright, now that I used the CaipirinhaPilot and logging in, it still failed, BUT installing the new client (2023.11) fixed the problem now. Thank you for your assistance!