Mods won't download fully

Recently I have been unable to download any large mods, they seem to get stuck at the downloading stage but do not make any progress. This seems to only happen with larger mods, e.g. BlackOps FAF: Unleashed.
I can see the temp files in my cache, and they seem to get to somewhere between 1-15 MB downloaded, and then stop.

Any settings I can change to try to get around this issue? I've tried clearing the cache and updating the FAF client.

Not a solution but you can download all Black Ops FAF versions from here:

(it is the same version as in the vault)

Thanks Uveso. I did download it that way and it seemed to work, but then the mod was updated again and so I have the halfway-downloaded problem again. It used to work perfectly and it was so easy to join whatever custom game I wanted to, but now this issue is making most modded matches unplayable for me.

Has anyone else had this issue, or found a workaround?

@kiwiengineer Have you tried this setting?

I just tried changing the directory to a different one, but still run into the same issue.
The download creates a temporary file within my cache folder, but it never seems to finish. And it doesn't create a new folder for that mod within the new mods directory, so I guess it's not getting to the extracting/installing stage.