Unable to create Direct3D-> unable to change resolution

I've been afflicted by the Unable to create Direct3D issue on trying to set up a new laptop with GeForce 3080 Mobile. I've tried all the standard, older fixes - updating drivers, downgrading drivers for the last 3 releases with GameReady and WHQL versions, reinstalling the Steam package, editing or resetting game.prefs, what finally seemed to work is setting the default GPU in the nVidia Control Panel to the Geforce, instead of the onboard Iris, or Optimus auto switching; and disabling (disconnecting) my secondary monitor entirely on WHQL 528.49, the Feb-23 release. 3D-mode switching between the GPUs (iris/GeForce) did nothing to help the SupCom game.
Finally, the game actually starts using this manual driver selection method although this is a PITA anytime i want to play a game. Modern games switch back and forth no problem..

But now that the app doesn't immediately crash, it appears I can't edit the video resolution to anything other than the default 1024x768. I've tried everything from the default screen resolution (2k) 2560x1440 down to 1280x960 so far and all it generates is a grey screen with no video. The application continues to run and audio works fine but just a flat grey window forcing me to kill the app from task manager.

Does anyone have definitive fixes to work with a GeForce 3080? This is very frustrating as both desktop 2080s and Quadro RTX worked just fine at 4k. Does it require even older driver versions?

Just to make sure, the primary screen you are playing the game on is your inbuilt Laptop monitor, not an external monitor? If yes, im afraid i have no advise for you other than the generic "did you try reinstalling windows" answer.

You could try defining the resolution directly in the preference file, see if that helps.

A work of art is never finished, merely abandoned