Post Alpha update games still wont create + possible TM mod corruption?

Good afternoon, looking for some help with Creating games post alpha update, / Java fix download

There is also a possible Total mayhem corruption within either sound or mod folder, I've looked but I'm unsure of what to look for.

Things I've tried :
started with the actual client update - Still couldn't create games - updated to alpha - still the same issue,

Deselecting all the mods I use,
Uninstalling and re-installing Total Mayhem
Deselecting and trying for a default game,

i have a log from the error message, will post if needed,

A log would be certainly very helpful - Please post it.

Client Version: 2023.2.0-alpha-1
java.lang.RuntimeException: java.nio.file.AccessDeniedException: C:\ProgramData\FAForever\cache\featured_mod\bin\c79711d82393a4465ceeb9413673083b -> C:\ProgramData\FAForever\bin\ForgedAlliance.exe
at com.faforever.client.patch.SimpleHttpFeaturedModUpdaterTask.lambda$call$0(
at java.base/java.util.ArrayList.forEach(
at javafx.concurrent.Task$
at java.base/
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/
Caused by: java.nio.file.AccessDeniedException: C:\ProgramData\FAForever\cache\featured_mod\bin\c79711d82393a4465ceeb9413673083b -> C:\ProgramData\FAForever\bin\ForgedAlliance.exe
at java.base/sun.nio.fs.WindowsException.translateToIOException(
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(
at java.base/sun.nio.fs.WindowsFileCopy.copy(
at java.base/sun.nio.fs.WindowsFileSystemProvider.copy(
at java.base/java.nio.file.Files.copy(
at com.faforever.client.patch.SimpleHttpFeaturedModUpdaterTask.lambda$call$0(
... 8 more

Your security software is blocking it. For testing purpose, disable or/and whitelist FAF.

Thank you, i looked up how to do that and i think ive done so, but want to check cause its still not working, What specifically should i be whitelisting

so far ive done the C program file for faf forever and the c program file for the client,

If you are sure, it is not related to the security software, then check for user account permission.

You can go through those threads with the same error and their solution:

Edit: How to whitelist certain processes and files can vary for every user environment, you need to make sure you find out how you do it in your environment.

thank you it worked out, now to figure out how to fix the corrupted mods it seems to show the mods folder and the sounds folder in my notifications total mayhem it seems
ive tried uninstalling and re installing the mod,

is there a way i can troubleshoot it or pinpoint it?

You could try to remove the mod manually from the mod folder, then reinstall again, via FAF client, maybe the permission issues in the first place did some funky stuff to the mod folder. Total mayhem itself should work AFAIK.

If nothing works, you can remove all logs, recreate the problem and then post the latest logs - Thanks in advance.