Any way to stop the recurring appearance of "don't run as administrator" dialogue box

1

administrator account is my only account, I have to wait for it to show up and click "yes" every single time I start the client

0

Devs say "no". Has been asked thousands of times.

2

@mach said in Any way to stop the recurring appearance of "don't run as administrator" dialogue box:

administrator account is my only account, I have to wait for it to show up and click "yes" every single time I start the client

It does not matter if your user has the "Administrator" role. My user is admin as well and i don't get this warning. You get this warning if you start the client AS admin.

Don't do this:
4a596843-fcaa-4ba7-b3e8-3b5268bb27be-grafik.png

Don't do this:
454f2a52-7d5c-4733-a896-821acd96628a-grafik.png

And make sure that you have normal security settings an all relevant files and folders.

0

Just technically for windows these days if the user is admin and also has UAC turned off then everything is run with admin privileges by default

0

@katharsas said in Any way to stop the recurring appearance of "don't run as administrator" dialogue box:

It does not matter if your user has the "Administrator" role. My user is admin as well and i don't get this warning. You get this warning if you start the client AS admin.

I just normally open it (double click) and it gives me that dialogue box every time

0

@Mach

i also asked for this long time ago.
don't expect any help with this issue.

0

did you find any workaround?

1

Workaround: configure your windows as recommended by Microsoft

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
ā€“ Benno Rice

0

@brutus5000 How?

2

Enable UAC (this is what recommended by microsoft)
a10df901-f36f-43ca-b096-c6b4dc5f84e3-image.png
This can already be enough to solve the problem
Then make sure that users have rights to "C:\programdata\faforever" folder
or just delete it and the problem should no longer appear, FAF should redownload files with correct settings

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

is this dialogue box a client thing or a windows thing, because I can't find any other program that does this to find a solution? just to be sure I am talking about this:

alt text

0

@mach I solved this following the Zlo's post.

0

unfortunately I already had it set like that and it still pops up

0

@mach did you try to delete FAForever folder from programdata?
(or can move it if you care about content of it, like replays or custom strategic icons)

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

@zlo said in Any way to stop the recurring appearance of "don't run as administrator" dialogue box:

@mach did you try to delete FAForever folder from programdata?

I just did but same thing happens when I open FAF afterwards

0

I store all data on disk D, so I succeeded on the pressing-the-OK-button step.

0

@Mach
Make sure to rightclick the shortcut (what you double click) and make sure the admin option is disabled:

Screenshot 2023-02-08 002616.png

0

it is unchecked

0

Ok then pls also check this one:
a45b7a22-ee8a-43f6-a22b-7c985c81d783-image.png

If that does not help then i would say your windows or FAF install has been fiddled with by some third party program (any "Tuning" programs or similar running?) in a bad way.

0

oh I dont have that tab, I was using the .exe itself, not a shortcut