DeviceD3D9.cpp(189) problem but why, game prefs is not the problem(in my case I think))

0

Since my childhood I played SCFA (10 years ago approx.), in the past of the years my 10 old hardware is no longer capable to run modern games with max graphics/frame rates, i reformatted my computer i found that there is FAF, so i tried to play it , but got DirectX 3d problem
I tried to fix it doing the next list but not successful:
Gameprefs didn't appear in the first time i create one using steam tutorial.
update, windows 10 , GeForce experience (i have gtx 970), java,
directx9 , Microsoft visual 2010(vcredist).
eliminating game archives and the problem is inside gamedata/mogodata.scd
supcom says DeviceD3D9.cpp(189) problem.
Then i create a account here, download FAF client, try the tutorials and the same
Tried playing with 1280x768 resolution
Tried use specific changes using NVidia control panel mange3dsettings program settings SCFA, all on and all of
verify integrity on steam, uninstall, reinstall, download again without antivirus or windows protection
Compatibility(Tried win 7, 8, xp servicepack)
That's all I think,
one monitor Spectre E20, camera, mouse, keyboard 1 hdd, computer x64basedpc gtx 970 nvidia
Games i play after the reformat. the bureau xcom, league of legends, terraria, and rimworld
i have DirectX 12 using dxdiag directdraw direct 3d agp texture all enable

i have 24gb ram 8 usable the others go to the gpu, no problem with heat (using MSI afterburner)
played SCFA before but like 8 years ago (windows 7), same computer only change the power supply, monitor and hdd,

if i left my DirectX3d problem run more time, go bugsplat, and the next file is created

dxdiag.txt

pretty sure I'm doom but, if any chance to play SCFA with out using GeForce now (1 hour of gameplay is not enough)i will tried.

0

Could you share the exact error trace / log that the game provides? If it is a long log, you can use www.pastebin.com to share it with us. Your system specs are not out of the ordinary, it should be able to run the game just fine.

A work of art is never finished, merely abandoned

0

@Jip What do you mean with trace / log that the game provides?
if you mean de Supcom file(appdata) or other? or the FAF logs?

0

supcom says DeviceD3D9.cpp(189) problem.

The log that states this

A work of art is never finished, merely abandoned

0

[link text](SupcomProblem.txt link url)

can't upload the original file but here is in txt.

0

@hahfle also FAF log similar
tell me if can't be openDeviceD3d9butFAFTryingTutorial.txt

0

Have you started the game at least once via Steam, and are you trying to start it with dual monitor setup enabled?

A work of art is never finished, merely abandoned

0

There is a possibility that when I played in geforce now it will be saved with the configuration in the cloud, because I remember not having a profile when I played again, last time played in my pc was 2016, geforcenow 2020, when i tried again in geforcenow, my profile still exist. so how i can delete the configuration in cloud? and no, my pc don't have dual monitor enable

0

I don't understand what you mean with geforcenow, FAF also has no configurations in the cloud.

A work of art is never finished, merely abandoned

0

ok, gonna try something crazy, SCFA cost me just like 1 or 2 dolar in 2015, now i going to delete the game from my steam account, should delete everything saved(my computer and steam servers) 10 dolars to play again is not big deal

0

I don't think that will solve your issue. It will download the same files again

A work of art is never finished, merely abandoned

0

are you playing via steamdeck

Iā€™m a shitty 1k Global. Any balance or gameplay suggestions should be understood or taken as such.

Project Head and current Owner/Manager of SCTA Project

0

not sure what was the problem, , i reformatted my computer again, no updates this time, only windows and java, runs fine
so, solved i guess, lost everything again but at least i can play now šŸ˜„