2D Sound

0

Hi, I have an issue with the sound. I don't have an issue with playing sounds actually, my issue is the opposite. I can hear everything at the same time.

All sounds play as they are near to me. I supposed it was a feature of the old game, but later I checked a youtube stream and the sound was in a complete 3D environment.

I tried all recommendations:

  1. change settings to stereo and 441khz
  2. reset game settings

It doesn't help.

Could somebody help me to fix it?

0

Make sure 3d spatial sound or any Dolby etc for 3d are not enabled in sounds properties. This will also cause this.

If you are using a USB headset some off those may have their own control panel which will also have 3d settings that may require disabling.

0

I tried everything I could with a USB 3d sound headset. Didn't get it to work. In the end I am using 2 headsets. One for FAF and one for other purposes.

Check out my maps here:

Madness 1 - 9

https://forum.faforever.com/topic/480/h-master-s-maps

0

I have the same issue with a steel series arctus 7. What works for me is APO equalizer. But you have to run the configurator, select the audio device, click troubleshooting and install as SFX/efx. This fixes it for me. There is a peace gui that can also be downloaded for a graphical equalizer that is nice. The downside is that nearly any Windows update forces you to rerun the configurator app.

0

Hey, @macdeffy I have the same headset. Could you provide more detailed information about how to setup the APO equalizer?

1

https://sourceforge.net/projects/equalizerapo/

Is the download site. Simply install it, and look for configurator in apo equalizer section on start menu.

When you run it, you'll see a list of every audio device. You should see steel series gaming headset or similar. Select it, by clicking the box to the left. I think you also need to highlight the connector name or the troubleshooting box won't show at bottom. Once it does check the box and select Install as SFX/EFX from the drop down menu, and then apply and restart.

Now you still need to ensure all the other stereo settings are correct and 3d settings are disabled where applicable.

Something that was problem for me was installing the Sonar App in the steel series control panel. It creates a sonar Virtual audio device that supposedly mimics 8 channel stereo, which is also not good for FAF, but the problem was it would default to that audio device instead of the default Steel Series Gaming audio. Disabling it from the steel series had no effect, it would just reenable itself even if i disabled the audio device in device manager. So just uninstall Sonar.

Also make sure the steel series control panel isn't defaulting to 7.1 audio.